Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1665)

Issue 2572603002: ABANDONED CL: Rename readyState() to getReadyState(). (Closed)

Created:
4 years ago by Łukasz Anforowicz
Modified:
4 years ago
Reviewers:
esprehn
CC:
apavlov+blink_chromium.org, blink-reviews, blink-reviews-dom_chromium.org, caseq+blink_chromium.org, chromium-reviews, cmumford, dcheng, devtools-reviews_chromium.org, dglazkov+blink, eae+blinkwatch, eric.carlson_apple.com, feature-media-reviews_chromium.org, haraken, jsbell+idb_chromium.org, kozyatinskiy+blink_chromium.org, lushnikov+blink_chromium.org, mcasas+watch+mediastream_chromium.org, mlamouri+watch-blink_chromium.org, pfeldman+blink_chromium.org, rwlbuis, sof, Srirama, tommyw+watchlist_chromium.org, tyoshino+watch_chromium.org, yhirano+watch_chromium.org
Target Ref:
refs/pending/heads/master
Project:
chromium
Visibility:
Public.

Description

ABANDONED CL (see CR comments for more details and discussion) ---------------------------- Rename readyState() to getReadyState(). The rename is needed to avoid a naming collision after changing from Blink to Chromium naming style. Right now we have a |ReadyState| enum type and |readyState| accessor methods (differing by case of the first character); after a naive rename by the rewrite_to_chrome_style tool we would end up with |ReadyState| being the name of both the type and the accessor methods (with both living in the same namespace). Prepending a "get" prefix to the name of the accessor method is the workaround that fits into the guidance on the recommended post-Blink-to-Chromium-rename style suggested by esprehn@ in https://crbug.com/582312#c17: - Getters favor not using "Get", ex. FirstChild() - Unless the type name conflicts, in which case you can either rename the type if it's easy and makes sense, or add "Get", ex. GetContext(). BUG=582312

Patch Set 1 #

Total comments: 8
Unified diffs Side-by-side diffs Delta from patch set Stats (+89 lines, -89 lines) Patch
M third_party/WebKit/Source/core/dom/Document.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/core/dom/Document.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/dom/Document.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/inspector/InspectorTraceEvents.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/xmlhttprequest/XMLHttpRequest.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/core/xmlhttprequest/XMLHttpRequest.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/xmlhttprequest/XMLHttpRequest.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/core/xmlhttprequest/XMLHttpRequestProgressEventThrottle.cpp View 4 chunks +5 lines, -5 lines 0 comments Download
M third_party/WebKit/Source/modules/eventsource/EventSource.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/eventsource/EventSource.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/eventsource/EventSource.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/imagecapture/ImageCapture.cpp View 1 chunk +2 lines, -2 lines 0 comments Download
M third_party/WebKit/Source/modules/indexeddb/IDBRequest.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/indexeddb/IDBRequest.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/indexeddb/IDBRequest.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/indexeddb/IDBRequestTest.cpp View 4 chunks +4 lines, -4 lines 0 comments Download
M third_party/WebKit/Source/modules/mediasource/MediaSource.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/mediasource/MediaSource.cpp View 4 chunks +4 lines, -4 lines 0 comments Download
M third_party/WebKit/Source/modules/mediasource/MediaSource.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/mediastream/MediaStreamTrack.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/mediastream/MediaStreamTrack.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/mediastream/MediaStreamTrack.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/peerconnection/RTCDataChannel.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/peerconnection/RTCDataChannel.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/peerconnection/RTCDataChannel.idl View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/websockets/DOMWebSocket.h View 1 chunk +1 line, -1 line 1 comment Download
M third_party/WebKit/Source/modules/websockets/DOMWebSocket.cpp View 1 chunk +1 line, -1 line 0 comments Download
M third_party/WebKit/Source/modules/websockets/DOMWebSocketTest.cpp View 32 chunks +50 lines, -50 lines 0 comments Download
M third_party/WebKit/Source/modules/websockets/WebSocket.idl View 1 chunk +1 line, -1 line 0 comments Download

Messages

Total messages: 13 (7 generated)
Łukasz Anforowicz
esprehn@, could you PTAL? FWIW, I've searched for "ReadyState" under out/.../gen and everything looks okay ...
4 years ago (2016-12-12 22:01:44 UTC) #5
esprehn
Where is the ReadyState enum used? the idl has DocumentReadyState as the enum, maybe we ...
4 years ago (2016-12-12 22:09:38 UTC) #6
Łukasz Anforowicz
On 2016/12/12 22:09:38, esprehn wrote: > Where is the ReadyState enum used? There are 10 ...
4 years ago (2016-12-12 22:43:49 UTC) #7
esprehn
Right, just rename all the ReadyState enums to ReadyStateType or something.
4 years ago (2016-12-12 23:01:11 UTC) #8
Łukasz Anforowicz
On 2016/12/12 23:01:11, esprehn wrote: > Right, just rename all the ReadyState enums to ReadyStateType ...
4 years ago (2016-12-13 00:14:44 UTC) #9
Łukasz Anforowicz
4 years ago (2016-12-22 17:36:18 UTC) #12
On 2016/12/13 00:14:44, Łukasz Anforowicz wrote:
> On 2016/12/12 23:01:11, esprehn wrote:
> > Right, just rename all the ReadyState enums to ReadyStateType or something.
> 
> Ok.  I agree that Document::ReadyState -> Document::DocumentReadyState is
better
> than the changes originally proposed in this CL.  Let me do exactly this
rename
> in https://codereview.chromium.org/2567943004.
> 
> I'll keep the CL under review opened for a little while, until I figure out
what
> to do with the remaining conflicts in
> - third_party/WebKit/Source/modules/indexeddb/IDBRequest.h
> - third_party/WebKit/Source/modules/mediasource/MediaSource.h and
> third_party/WebKit/Source/platform/mediastream/MediaStreamSource.h
> (either spinning them off into separate CL like I did with
Document::ReadyState
> or handling them right here).

Abandoning this CL - nasko@ says that we don't have a class-vs-method anymore
with the remaining cases of readyState.

Powered by Google App Engine
This is Rietveld 408576698