DescriptionUse tighter typing in table rendering code
Use tighter typing in table rendering code:
- Rename RenderTableSection's firstChild() / lastChild() to firstRow() / lastRow()
and have them return a RenderTableRow* instead of a RenderObject*.
- Rename RenderTableRow's firstChild() / lastChild() to firstCell() / lastCell()
and have them return a RenderTableCell* instead of a RenderObject*.
Add previousRow() / nextRow() methods to RenderTableRow and previousCell() /
nextCell() to RenderTableCell to make traversal code more readable. Also hide
RenderObject's previousSibling() / nextSibling() in those classes to make sure
the more specialized methods are called.
This is based on WebKit r156355 by Antti Koivisto (antti@apple.com):
https://trac.webkit.org/r156355
R=esprehn@chromium.org, pdr@chromium.org
Committed: https://src.chromium.org/viewvc/blink?view=rev&revision=174403
Patch Set 1 #Patch Set 2 : Add missing inlines #Patch Set 3 : Fix typo / bug and update copyrights #
Total comments: 5
Messages
Total messages: 9 (0 generated)
|