Dry run: Try jobs failed on following builders: cast_shell_android on master.tryserver.chromium.android (JOB_FAILED, https://build.chromium.org/p/tryserver.chromium.android/builders/cast_shell_android/builds/257956)
3 years, 7 months ago
(2017-04-29 00:37:13 UTC)
#4
Description was changed from ========== Rename KeyLock to KeyboardLock and return enum from IPC BUG=680809 ...
3 years, 7 months ago
(2017-04-29 01:36:01 UTC)
#8
Description was changed from
==========
Rename KeyLock to KeyboardLock and return enum from IPC
BUG=680809
==========
to
==========
Rename KeyLock to KeyboardLock and return enum from IPC
This change addresses one remaining work in change
https://codereview.chromium.org/2805763004/ to modify the return value of
RequestKeyLock() mojom interface from (bool, string) to an enumeration.
Meanwhile, after discussing with Gary (GaryKac@), we would prefer to keep
"Keyboard" as part of the function name. So all "KeyLock"s are changed to
"KeyboardLock".
BUG=680809
==========
commit-bot: I haz the power
The CQ bit was unchecked by commit-bot@chromium.org
3 years, 7 months ago
(2017-04-29 03:08:38 UTC)
#9
This is a follow up change to address several of unresolved comments in https://codereview.chromium.org/2805763004/. As ...
3 years, 7 months ago
(2017-05-01 17:53:23 UTC)
#12
This is a follow up change to address several of unresolved comments in
https://codereview.chromium.org/2805763004/.
As the description, it contains renaming of the JS API and the return type of
mojom interface.
Avi (use Gerrit)
lgtm stamp
3 years, 7 months ago
(2017-05-01 18:06:48 UTC)
#13
lgtm
stamp
whywhat
lgtm do you intend to throw an exception with a different message based on the ...
3 years, 7 months ago
(2017-05-02 02:02:27 UTC)
#14
lgtm
do you intend to throw an exception with a different message based on the
failure type later on?
haraken
WebKit LGTM
3 years, 7 months ago
(2017-05-02 04:39:59 UTC)
#15
WebKit LGTM
Hzj_jie
On 2017/05/02 02:02:27, whywhat wrote: > lgtm > > do you intend to throw an ...
3 years, 7 months ago
(2017-05-02 04:45:15 UTC)
#16
On 2017/05/02 02:02:27, whywhat wrote:
> lgtm
>
> do you intend to throw an exception with a different message based on the
> failure type later on?
Before we decide to involve permission control for this feature -- I doubt we
will never do it, Chrome does not return Failure. So
navigator.requestKeyboardLock() never fails except for parallel requests. (In
navigator-requestKeyLock-two-parallel-requests.https.html.)
But since we need to know when the execution of the API has been finished
anyway, RequestKeyboardLock() mojom API needs to have a return value.
dcheng
lgtm https://codereview.chromium.org/2852823002/diff/20001/third_party/WebKit/public/platform/modules/keyboard_lock/keyboard_lock.mojom File third_party/WebKit/public/platform/modules/keyboard_lock/keyboard_lock.mojom (right): https://codereview.chromium.org/2852823002/diff/20001/third_party/WebKit/public/platform/modules/keyboard_lock/keyboard_lock.mojom#newcode9 third_party/WebKit/public/platform/modules/keyboard_lock/keyboard_lock.mojom:9: FAILURE = 1, // Chrome never returns a ...
3 years, 7 months ago
(2017-05-02 07:38:16 UTC)
#17
CQ is committing da patch. Bot data: {"patchset_id": 40001, "attempt_start_ts": 1493763133405750, "parent_rev": "c3efb07dd4212081ae8ad66551feba3ae21ba417", "commit_rev": "b67deca63eb94ec8e8fef981b0581d35ed7341fe"}
3 years, 7 months ago
(2017-05-02 22:18:44 UTC)
#26
CQ is committing da patch.
Bot data: {"patchset_id": 40001, "attempt_start_ts": 1493763133405750,
"parent_rev": "c3efb07dd4212081ae8ad66551feba3ae21ba417", "commit_rev":
"b67deca63eb94ec8e8fef981b0581d35ed7341fe"}
commit-bot: I haz the power
Description was changed from ========== Rename KeyLock to KeyboardLock and return enum from IPC This ...
3 years, 7 months ago
(2017-05-02 22:18:54 UTC)
#27
Message was sent while issue was closed.
Description was changed from
==========
Rename KeyLock to KeyboardLock and return enum from IPC
This change addresses one remaining work in change
https://codereview.chromium.org/2805763004/ to modify the return value of
RequestKeyLock() mojom interface from (bool, string) to an enumeration.
Meanwhile, after discussing with Gary (GaryKac@), we would prefer to keep
"Keyboard" as part of the function name. So all "KeyLock"s are changed to
"KeyboardLock".
BUG=680809
==========
to
==========
Rename KeyLock to KeyboardLock and return enum from IPC
This change addresses one remaining work in change
https://codereview.chromium.org/2805763004/ to modify the return value of
RequestKeyLock() mojom interface from (bool, string) to an enumeration.
Meanwhile, after discussing with Gary (GaryKac@), we would prefer to keep
"Keyboard" as part of the function name. So all "KeyLock"s are changed to
"KeyboardLock".
BUG=680809
Review-Url: https://codereview.chromium.org/2852823002
Cr-Commit-Position: refs/heads/master@{#468791}
Committed:
https://chromium.googlesource.com/chromium/src/+/b67deca63eb94ec8e8fef981b058...
==========
commit-bot: I haz the power
Committed patchset #2 (id:40001) as https://chromium.googlesource.com/chromium/src/+/b67deca63eb94ec8e8fef981b0581d35ed7341fe
3 years, 7 months ago
(2017-05-02 22:18:56 UTC)
#28
Issue 2852823002: Rename KeyLock to KeyboardLock and return enum from IPC
(Closed)
Created 3 years, 7 months ago by Hzj_jie
Modified 3 years, 7 months ago
Reviewers: whywhat, Avi (use Gerrit), dcheng, foolip, haraken
Base URL:
Comments: 2