Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(221)

Unified Diff: net/cookies/cookie_store.h

Issue 2595703002: Expand net::CookieStore::ChangeCause::EXPLICIT for debugging. (Closed)
Patch Set: better names for enum values Created 4 years ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « net/cookies/cookie_monster_unittest.cc ('k') | no next file » | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: net/cookies/cookie_store.h
diff --git a/net/cookies/cookie_store.h b/net/cookies/cookie_store.h
index 32bb1350fdf867c2fefc6b498e7a805e56958cef..63241b5e59a70bd16d2a1d89e713cb0649be2237 100644
--- a/net/cookies/cookie_store.h
+++ b/net/cookies/cookie_store.h
@@ -36,7 +36,14 @@ class NET_EXPORT CookieStore {
// The cookie was inserted.
INSERTED,
// The cookie was changed directly by a consumer's action.
- EXPLICIT,
+ // The following enum values all have the same meaning, but are being used
+ // to track down where a bug came from.
+ // TODO(nharper): Remove all but one of these and rename to EXPLICIT once
+ // the one of interest has been found.
+ EXPLICIT_DELETE,
+ EXPLICIT_DUPLICATE_IN_BACKING_STORE,
+ EXPLICIT_DONT_RECORD,
+ EXPLICIT_LAST_ENTRY,
// The cookie was deleted, but no more details are known.
UNKNOWN_DELETION,
// The cookie was automatically removed due to an insert operation that
« no previous file with comments | « net/cookies/cookie_monster_unittest.cc ('k') | no next file » | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698