Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1657)

Unified Diff: Source/platform/scheduler/CancellableTaskFactory.h

Issue 937883003: Rename CancellableTaskFactory::task() for clarity. (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@master
Patch Set: Rebase Created 5 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: Source/platform/scheduler/CancellableTaskFactory.h
diff --git a/Source/platform/scheduler/CancellableTaskFactory.h b/Source/platform/scheduler/CancellableTaskFactory.h
index 7e44bcb5ffc50b550e317d9bc521a0540c7d098d..66fe63ac27b1ba293ec3ff18d4093455ef58a852 100644
--- a/Source/platform/scheduler/CancellableTaskFactory.h
+++ b/Source/platform/scheduler/CancellableTaskFactory.h
@@ -36,7 +36,7 @@ public:
// Returns a task that can be disabled by calling cancel(). The user takes
// ownership of the task. Creating a new task cancels any previous ones.
- WebThread::Task* task();
+ WebThread::Task* cancelAndCreate();
private:
class CancellableTask : public WebThread::Task {
« no previous file with comments | « Source/core/html/parser/HTMLParserScheduler.cpp ('k') | Source/platform/scheduler/CancellableTaskFactory.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698