Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1233)

Unified Diff: cc/surfaces/surface_observer.h

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: cc/surfaces/surface_observer.h
diff --git a/cc/surfaces/surface_observer.h b/cc/surfaces/surface_observer.h
index c57f07e5f2583e6c8103672db1aac9db4cd125ff..c6a0ff01d8d7bc022cd0f6f35da5dec8c8fe53a4 100644
--- a/cc/surfaces/surface_observer.h
+++ b/cc/surfaces/surface_observer.h
@@ -38,6 +38,9 @@ class SurfaceObserver {
// and, thus, is expected to produce damage soon.
virtual void OnSurfaceDamageExpected(const SurfaceId& surface_id,
const BeginFrameArgs& args) = 0;
+
+ // Runs when SurfaceAggregator has added the surface to the Display Frame.
+ virtual void OnSurfaceWillDraw(const SurfaceId& surface_id) = 0;
};
} // namespace cc

Powered by Google App Engine
This is Rietveld 408576698