Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(3868)

Unified Diff: cc/test/fake_surface_observer.h

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: cc/test/fake_surface_observer.h
diff --git a/cc/test/fake_surface_observer.h b/cc/test/fake_surface_observer.h
index bf325e7d5b0892583740536a339bc1e86b087099..bd3a359bf23d1132802f79c98e626c33a4c1b2f7 100644
--- a/cc/test/fake_surface_observer.h
+++ b/cc/test/fake_surface_observer.h
@@ -42,6 +42,7 @@ class FakeSurfaceObserver : public SurfaceObserver {
void OnSurfaceDestroyed(const SurfaceId& surface_id) override {}
void OnSurfaceDamageExpected(const SurfaceId& surface_id,
const BeginFrameArgs& args) override {}
+ void OnSurfaceWillDraw(const SurfaceId& surface_id) overide {}
bool damage_display_;
BeginFrameAck last_ack_;

Powered by Google App Engine
This is Rietveld 408576698