Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(902)

Unified Diff: cc/surfaces/surface_manager.cc

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: cc/surfaces/surface_manager.cc
diff --git a/cc/surfaces/surface_manager.cc b/cc/surfaces/surface_manager.cc
index 3972a9d198688acfbaad54f80c613cc22780fa2c..6168c5dd2efbb04d563e2a0b5c4616ddd8fb4fcd 100644
--- a/cc/surfaces/surface_manager.cc
+++ b/cc/surfaces/surface_manager.cc
@@ -124,6 +124,12 @@ void SurfaceManager::DestroySurface(std::unique_ptr<Surface> surface) {
GarbageCollectSurfaces();
}
+void SurfaceManager::SurfaceWillDraw(const SurfaceId& surface_id) {
+ DCHECK(thread_checker_.CalledOnValidThread());
+ for (auto& observer : observer_list_)
+ observer.OnSurfaceWillDraw(surface_id);
+}
+
void SurfaceManager::RequireSequence(const SurfaceId& surface_id,
const SurfaceSequence& sequence) {
auto* surface = GetSurfaceForId(surface_id);

Powered by Google App Engine
This is Rietveld 408576698