Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2645)

Unified Diff: cc/surfaces/surface_manager.h

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: cc/surfaces/surface_manager.h
diff --git a/cc/surfaces/surface_manager.h b/cc/surfaces/surface_manager.h
index 73b1b25040b922a530d439b296e421eb6e541aa3..cfc216358d9a9ba5cd3402156c5e18706cdff986 100644
--- a/cc/surfaces/surface_manager.h
+++ b/cc/surfaces/surface_manager.h
@@ -74,6 +74,10 @@ class CC_SURFACES_EXPORT SurfaceManager {
// Destroy the Surface once a set of sequence numbers has been satisfied.
void DestroySurface(std::unique_ptr<Surface> surface);
+ // Called when a surface has been added to the Display Frame and will
+ // invoke observers with the OnSurfaceWillDraw notification.
+ void SurfaceWillDraw(const SurfaceId& surface_id);
+
Surface* GetSurfaceForId(const SurfaceId& surface_id);
void AddObserver(SurfaceObserver* obs) { observer_list_.AddObserver(obs); }

Powered by Google App Engine
This is Rietveld 408576698