Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(189)

Unified Diff: cc/surfaces/surface_aggregator.cc

Issue 2908783002: WIP Hittest Component.
Patch Set: change HitTestFlags to constants so we can mix and match and convert to struct naming convention Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: cc/surfaces/surface_aggregator.cc
diff --git a/cc/surfaces/surface_aggregator.cc b/cc/surfaces/surface_aggregator.cc
index f0e73f8a06a835fdb22d2368cad0415218225dd2..bde4f820a843b2c03f426f6873e9808798cde9e1 100644
--- a/cc/surfaces/surface_aggregator.cc
+++ b/cc/surfaces/surface_aggregator.cc
@@ -760,8 +760,10 @@ gfx::Rect SurfaceAggregator::PrewalkTree(const SurfaceId& surface_id,
CHECK(debug_weak_this.get());
// TODO(staraz): It shouldn't need to call the callback when the damage is
// from |surface| and not from |child_surfaces|.
- if (!damage_rect.IsEmpty())
+ if (!damage_rect.IsEmpty()) {
surface->RunWillDrawCallback(damage_rect);
+ manager_->SurfaceWillDraw(surface->surface_id());
+ }
CHECK(debug_weak_this.get());
for (const auto& render_pass : frame.render_pass_list) {

Powered by Google App Engine
This is Rietveld 408576698