Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(263)

Unified Diff: third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h

Issue 2893823004: [Payments] Implement openWindow for service worker based payment handler (Closed)
Patch Set: format Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h
diff --git a/third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h b/third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h
index 5cd7c05bc18ba7d725aa733c2c876b9472055086..1427c9835ca383f87d0355e5b92974b26e337be9 100644
--- a/third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h
+++ b/third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h
@@ -29,6 +29,10 @@ class ServiceWorkerClients final
ScriptPromise openWindow(ScriptState*, const String& url);
ScriptPromise claim(ScriptState*);
+ ScriptPromise openWindow(ScriptState*,
please use gerrit instead 2017/05/25 14:53:27 Perhaps a better name for this method would be a m
gogerald1 2017/05/25 16:53:32 This interface is also used by service worker, so
zino 2017/05/25 17:02:42 +1 I agree with rouslan@'s opinion.
gogerald1 2017/05/29 22:13:16 Done.
+ const String& redirect_url,
+ const String& url);
+
DEFINE_INLINE_TRACE() {}
private:

Powered by Google App Engine
This is Rietveld 408576698