Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(508)

Side by Side Diff: third_party/WebKit/Source/modules/serviceworkers/ServiceWorkerClients.h

Issue 2893823004: [Payments] Implement openWindow for service worker based payment handler (Closed)
Patch Set: format Created 3 years, 6 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
1 // Copyright 2014 The Chromium Authors. All rights reserved. 1 // Copyright 2014 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be 2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file. 3 // found in the LICENSE file.
4 4
5 #ifndef ServiceWorkerClients_h 5 #ifndef ServiceWorkerClients_h
6 #define ServiceWorkerClients_h 6 #define ServiceWorkerClients_h
7 7
8 #include "modules/serviceworkers/ClientQueryOptions.h" 8 #include "modules/serviceworkers/ClientQueryOptions.h"
9 #include "platform/bindings/ScriptWrappable.h" 9 #include "platform/bindings/ScriptWrappable.h"
10 #include "platform/heap/Handle.h" 10 #include "platform/heap/Handle.h"
(...skipping 11 matching lines...) Expand all
22 22
23 public: 23 public:
24 static ServiceWorkerClients* Create(); 24 static ServiceWorkerClients* Create();
25 25
26 // Clients.idl 26 // Clients.idl
27 ScriptPromise get(ScriptState*, const String& id); 27 ScriptPromise get(ScriptState*, const String& id);
28 ScriptPromise matchAll(ScriptState*, const ClientQueryOptions&); 28 ScriptPromise matchAll(ScriptState*, const ClientQueryOptions&);
29 ScriptPromise openWindow(ScriptState*, const String& url); 29 ScriptPromise openWindow(ScriptState*, const String& url);
30 ScriptPromise claim(ScriptState*); 30 ScriptPromise claim(ScriptState*);
31 31
32 ScriptPromise openWindow(ScriptState*,
please use gerrit instead 2017/05/25 14:53:27 Perhaps a better name for this method would be a m
gogerald1 2017/05/25 16:53:32 This interface is also used by service worker, so
zino 2017/05/25 17:02:42 +1 I agree with rouslan@'s opinion.
gogerald1 2017/05/29 22:13:16 Done.
33 const String& redirect_url,
34 const String& url);
35
32 DEFINE_INLINE_TRACE() {} 36 DEFINE_INLINE_TRACE() {}
33 37
34 private: 38 private:
35 ServiceWorkerClients(); 39 ServiceWorkerClients();
36 }; 40 };
37 41
38 } // namespace blink 42 } // namespace blink
39 43
40 #endif // ServiceWorkerClients_h 44 #endif // ServiceWorkerClients_h
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698