Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(354)

Unified Diff: third_party/WebKit/Source/core/workers/Worklet.h

Issue 2826983002: Rename Worklet.import() to Worklet.addModule(). (Closed)
Patch Set: Fixing Layout Tests Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/workers/Worklet.h
diff --git a/third_party/WebKit/Source/core/workers/Worklet.h b/third_party/WebKit/Source/core/workers/Worklet.h
index f482229f2e93cd6f16668eaece83181980d592a2..07122bda3c915bba916cf1c790d422169b002349 100644
--- a/third_party/WebKit/Source/core/workers/Worklet.h
+++ b/third_party/WebKit/Source/core/workers/Worklet.h
@@ -34,8 +34,8 @@ class CORE_EXPORT Worklet : public GarbageCollectedFinalized<Worklet>,
virtual bool IsInitialized() const { return true; }
// Worklet.idl
- // import() imports ES6 module scripts.
- virtual ScriptPromise import(ScriptState*, const String& url) = 0;
+ // addModule() imports ES6 module scripts.
+ virtual ScriptPromise addModule(ScriptState*, const String& url) = 0;
// Returns a proxy to WorkletGlobalScope on the context thread.
virtual WorkletGlobalScopeProxy* GetWorkletGlobalScopeProxy() const = 0;
« no previous file with comments | « third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp ('k') | third_party/WebKit/Source/core/workers/Worklet.idl » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698