Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(685)

Unified Diff: third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp

Issue 2826983002: Rename Worklet.import() to Worklet.addModule(). (Closed)
Patch Set: Fixing Layout Tests Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp
diff --git a/third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp b/third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp
index d60cdedd801dff8182ac3efe1965388fbfe1285b..58497b5077fb6b9824313a8eb5d61a50559c578d 100644
--- a/third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp
+++ b/third_party/WebKit/Source/core/workers/ThreadedWorklet.cpp
@@ -17,8 +17,8 @@ namespace blink {
ThreadedWorklet::ThreadedWorklet(LocalFrame* frame) : Worklet(frame) {}
-ScriptPromise ThreadedWorklet::import(ScriptState* script_state,
- const String& url) {
+ScriptPromise ThreadedWorklet::addModule(ScriptState* script_state,
+ const String& url) {
DCHECK(IsMainThread());
if (!GetExecutionContext()) {
return ScriptPromise::RejectWithDOMException(
« no previous file with comments | « third_party/WebKit/Source/core/workers/ThreadedWorklet.h ('k') | third_party/WebKit/Source/core/workers/Worklet.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698