|
|
DescriptionMove DocumentMarkerListEditor to its own .h/.cpp files
Based on Step 2 of yosin's plan:
https://codereview.chromium.org/2812423002#msg7
This is a follow-up to this CL where the DocumentMarkerListEditor class
was created inside DocumentMarkerController:
https://codereview.chromium.org/2812423002
BUG=707867
Review-Url: https://codereview.chromium.org/2818873002
Cr-Commit-Position: refs/heads/master@{#466224}
Committed: https://chromium.googlesource.com/chromium/src/+/37c5a8829c124800330ab1965fa29615465551e9
Patch Set 1 #Patch Set 2 : Actually remove DocumentMarkerListEditor from DMC header #Patch Set 3 : Rebase #Patch Set 4 : Rebase #
Total comments: 1
Patch Set 5 : Don't accidentally include https://codereview.chromium.org/2820983002 #Patch Set 6 : Rebase to fix trybot #
Total comments: 4
Patch Set 7 : Rebase, rename rhv #
Total comments: 2
Patch Set 8 : Add DocumentMarker::EndsBefore() #
Total comments: 1
Patch Set 9 : Rebase #Patch Set 10 : Rebase (EndsBefore is a lambda now) #
Total comments: 1
Patch Set 11 : Remove static comparator functions from DocumentMarkerListEditor #
Depends on Patchset: Dependent Patchsets: Messages
Total messages: 65 (43 generated)
Description was changed from ========== Move DocumentMarkerListEditor to its own .h/.cpp files BUG=707867 ========== to ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 BUG=707867 ==========
rlanday@chromium.org changed reviewers: + xiaochengh@chromium.org, yosin@chromium.org
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
rlanday@chromium.org changed reviewers: + yoichio@chromium.org
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Rebased
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:270: if (DocumentMarkerListEditor::MoveMarkers(src_list, length, dst_list)) Doesn't seem properly rebased... There should be only code move in this patch.
Description was changed from ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 BUG=707867 ========== to ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 This is a follow-up to this CL where the DocumentMarkerListEditor class was created inside DocumentMarkerController: https://codereview.chromium.org/2812423002 BUG=707867 ==========
Description was changed from ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 This is a follow-up to this CL where the DocumentMarkerListEditor class was created inside DocumentMarkerController: https://codereview.chromium.org/2812423002 BUG=707867 ========== to ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 This is a follow-up to this CL where the DocumentMarkerListEditor class was created inside DocumentMarkerController: https://codereview.chromium.org/2812423002 BUG=707867 ==========
On 2017/04/18 at 04:29:57, xiaochengh wrote: > https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... > File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): > > https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... > third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:270: if (DocumentMarkerListEditor::MoveMarkers(src_list, length, dst_list)) > Doesn't seem properly rebased... There should be only code move in this patch. ah I think I accidentally uploaded two patches together...
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
On 2017/04/18 at 05:02:13, rlanday wrote: > On 2017/04/18 at 04:29:57, xiaochengh wrote: > > https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... > > File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): > > > > https://codereview.chromium.org/2818873002/diff/60001/third_party/WebKit/Sour... > > third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:270: if (DocumentMarkerListEditor::MoveMarkers(src_list, length, dst_list)) > > Doesn't seem properly rebased... There should be only code move in this patch. > > ah I think I accidentally uploaded two patches together... Fixed
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: Try jobs failed on following builders: chromium_presubmit on master.tryserver.chromium.linux (JOB_FAILED, http://build.chromium.org/p/tryserver.chromium.linux/builders/chromium_presub...)
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:662: static bool EndsBefore(size_t start_offset, It's weird to have a chunk of new code in an old file in a patch named "move code". It's also bad to have the same function duplicated in two files. How about moving these static functions to, say, DocumentMarker as static members first? So that they can be used everywhere without having duplicate code. Btw, can these functions take |const DocumentMarker*| as parameters? If so, we can do things like: 1. Change these functions to take |const DocumentMarker*| instead of |const Member<RDM>&| 2. Move these functions as static members of DocumentMarker
https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:663: const Member<RenderedDocumentMarker>& rhv) { Please use descriptive parameter name instead of |rhv|, I could not get what this stands for...
https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:662: static bool EndsBefore(size_t start_offset, On 2017/04/19 at 03:33:23, Xiaocheng wrote: > It's weird to have a chunk of new code in an old file in a patch named "move code". It's also bad to have the same function duplicated in two files. This isn't new code, I moved it because I thought it made sense to put it closer to where it's used since I was removing the other functions it was grouped with. https://codereview.chromium.org/2818873002/diff/100001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:663: const Member<RenderedDocumentMarker>& rhv) { On 2017/04/20 at 01:43:01, yosin_UTC9 wrote: > Please use descriptive parameter name instead of |rhv|, I could not get what this stands for... I'm only moving this code; I think it stands for "right-hand value", but we can call it something like "marker" if that's better...
On 2017/04/19 at 03:33:23, xiaochengh wrote: > How about moving these static functions to, say, DocumentMarker as static members first? So that they can be used everywhere without having duplicate code. I think we should do this if/when we actually end up using these methods in multiple files (e.g. in multiple DocumentMarkerList implementations) > Btw, can these functions take |const DocumentMarker*| as parameters? Yes, that works
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Updated
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:662: static bool EndsBefore(size_t start_offset, Moving this function in the same file is an unnecessary change. Besides, we shouldn't have duplicated code in different files. Please either fix it or add a TODO for deduplication.
On 2017/04/20 at 03:09:15, xiaochengh wrote: > https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... > File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): > > https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... > third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:662: static bool EndsBefore(size_t start_offset, > Moving this function in the same file is an unnecessary change. > > Besides, we shouldn't have duplicated code in different files. Please either fix it or add a TODO for deduplication. Oh sorry, I missed that I'm using this in two places...
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp (right): https://codereview.chromium.org/2818873002/diff/110001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerController.cpp:662: static bool EndsBefore(size_t start_offset, On 2017/04/20 at 03:09:15, Xiaocheng wrote: > Moving this function in the same file is an unnecessary change. > > Besides, we shouldn't have duplicated code in different files. Please either fix it or add a TODO for deduplication. Fixed
Thanks for the change, but... https://codereview.chromium.org/2818873002/diff/130001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarker.h (right): https://codereview.chromium.org/2818873002/diff/130001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarker.h:183: static bool EndsBefore(size_t start_offset, const DocumentMarker*); Please split...
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
On 2017/04/20 at 03:40:37, xiaochengh wrote: > Thanks for the change, but... > > https://codereview.chromium.org/2818873002/diff/130001/third_party/WebKit/Sou... > File third_party/WebKit/Source/core/editing/markers/DocumentMarker.h (right): > > https://codereview.chromium.org/2818873002/diff/130001/third_party/WebKit/Sou... > third_party/WebKit/Source/core/editing/markers/DocumentMarker.h:183: static bool EndsBefore(size_t start_offset, const DocumentMarker*); > Please split... Ok, I have split it off into https://codereview.chromium.org/2828093004 and updated this patch
lgtm
lgtm Thanks!
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
https://codereview.chromium.org/2818873002/diff/170001/third_party/WebKit/Sou... File third_party/WebKit/Source/core/editing/markers/DocumentMarkerListEditor.cpp (right): https://codereview.chromium.org/2818873002/diff/170001/third_party/WebKit/Sou... third_party/WebKit/Source/core/editing/markers/DocumentMarkerListEditor.cpp:11: static bool StartsFurther(const Member<RenderedDocumentMarker>& lhv, Please also rebase this part. These two functions should also become lambdas.
The CQ bit was checked by rlanday@chromium.org to run a CQ dry run
On 2017/04/20 at 08:43:02, xiaochengh wrote: > https://codereview.chromium.org/2818873002/diff/170001/third_party/WebKit/Sou... > File third_party/WebKit/Source/core/editing/markers/DocumentMarkerListEditor.cpp (right): > > https://codereview.chromium.org/2818873002/diff/170001/third_party/WebKit/Sou... > third_party/WebKit/Source/core/editing/markers/DocumentMarkerListEditor.cpp:11: static bool StartsFurther(const Member<RenderedDocumentMarker>& lhv, > Please also rebase this part. These two functions should also become lambdas. Updated
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
lgtm
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: This issue passed the CQ dry run.
The CQ bit was checked by rlanday@chromium.org
The patchset sent to the CQ was uploaded after l-g-t-m from yosin@chromium.org Link to the patchset: https://codereview.chromium.org/2818873002/#ps190001 (title: "Remove static comparator functions from DocumentMarkerListEditor")
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
CQ is committing da patch. Bot data: {"patchset_id": 190001, "attempt_start_ts": 1492739684813090, "parent_rev": "90cbb1bd3931fb8ee58c729bbbcdb32f4915dd1f", "commit_rev": "37c5a8829c124800330ab1965fa29615465551e9"}
Message was sent while issue was closed.
Description was changed from ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 This is a follow-up to this CL where the DocumentMarkerListEditor class was created inside DocumentMarkerController: https://codereview.chromium.org/2812423002 BUG=707867 ========== to ========== Move DocumentMarkerListEditor to its own .h/.cpp files Based on Step 2 of yosin's plan: https://codereview.chromium.org/2812423002#msg7 This is a follow-up to this CL where the DocumentMarkerListEditor class was created inside DocumentMarkerController: https://codereview.chromium.org/2812423002 BUG=707867 Review-Url: https://codereview.chromium.org/2818873002 Cr-Commit-Position: refs/heads/master@{#466224} Committed: https://chromium.googlesource.com/chromium/src/+/37c5a8829c124800330ab1965fa2... ==========
Message was sent while issue was closed.
Committed patchset #11 (id:190001) as https://chromium.googlesource.com/chromium/src/+/37c5a8829c124800330ab1965fa2... |