Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1074)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentAppManager.idl

Issue 2785523003: PaymentHandler: Rename PaymentAppManager to PaymentManager. (Closed)
Patch Set: PaymentHandler: Rename PaymentAppManager to PaymentManager. Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentAppManager.idl
diff --git a/third_party/WebKit/Source/modules/payments/PaymentAppManager.idl b/third_party/WebKit/Source/modules/payments/PaymentAppManager.idl
deleted file mode 100644
index d97c5b2072f3e3ac965f6e9b6020b886cf7c3bc3..0000000000000000000000000000000000000000
--- a/third_party/WebKit/Source/modules/payments/PaymentAppManager.idl
+++ /dev/null
@@ -1,14 +0,0 @@
-// Copyright 2016 The Chromium Authors. All rights reserved.
-// Use of this source code is governed by a BSD-style license that can be
-// found in the LICENSE file.
-
-// https://w3c.github.io/webpayments-payment-apps-api/#idl-def-paymentappmanager
-
-[
- RuntimeEnabled=PaymentApp,
- ConstructorCallWith=ExecutionContext,
- DependentLifetime,
-] interface PaymentAppManager {
- [CallWith=ScriptState] Promise<void> setManifest(PaymentAppManifest manifest);
- [CallWith=ScriptState] Promise<PaymentAppManifest> getManifest();
-};

Powered by Google App Engine
This is Rietveld 408576698