Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(775)

Side by Side Diff: third_party/WebKit/Source/modules/payments/PaymentAppManager.idl

Issue 2785523003: PaymentHandler: Rename PaymentAppManager to PaymentManager. (Closed)
Patch Set: PaymentHandler: Rename PaymentAppManager to PaymentManager. Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch
OLDNEW
(Empty)
1 // Copyright 2016 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file.
4
5 // https://w3c.github.io/webpayments-payment-apps-api/#idl-def-paymentappmanager
6
7 [
8 RuntimeEnabled=PaymentApp,
9 ConstructorCallWith=ExecutionContext,
10 DependentLifetime,
11 ] interface PaymentAppManager {
12 [CallWith=ScriptState] Promise<void> setManifest(PaymentAppManifest manifest );
13 [CallWith=ScriptState] Promise<PaymentAppManifest> getManifest();
14 };
OLDNEW

Powered by Google App Engine
This is Rietveld 408576698