|
|
DescriptionRename functions in video frame to comply with Style Guide
BUG=None
CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel
Review-Url: https://codereview.chromium.org/2781283002
Cr-Commit-Position: refs/heads/master@{#463153}
Committed: https://chromium.googlesource.com/chromium/src/+/46944f80bfc35a8589514f8b8c9d895c21e17f2a
Patch Set 1 #
Total comments: 4
Patch Set 2 : Fixed compilation errors #
Total comments: 2
Patch Set 3 : Restored the comment related to enum STORAGE_DMABUFS #Patch Set 4 : Fixed compilation errors for MAC #
Messages
Total messages: 48 (27 generated)
Description was changed from ========== Rename functions in video frame to comply with Style Guide BUG=None ========== to ========== Rename functions in video frame to comply with Style Guide BUG=None ==========
uzair.jaleel@samsung.com changed reviewers: + a.suchit@chromium.org, mcasas@chromium.org
On 2017/03/30 05:44:37, Uzair wrote: > mailto:uzair.jaleel@samsung.com changed reviewers: > + mailto:a.suchit@chromium.org, mailto:mcasas@chromium.org PTAL
mcasas@chromium.org changed reviewers: + chfremer@chromium.org
On 2017/03/30 05:44:50, Uzair wrote: > On 2017/03/30 05:44:37, Uzair wrote: > > mailto:uzair.jaleel@samsung.com changed reviewers: > > + mailto:a.suchit@chromium.org, mailto:mcasas@chromium.org > > PTAL Please update description since you also change STORAGE_DMABUF to STORAGE_NATIVE. Otherwise doesn't look bad, adding chfremer@ for further review.
I am not an OWNER, but I am happy to give some feedback/raise some questions. https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h File media/base/video_frame.h (right): https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... media/base/video_frame.h:66: STORAGE_NATIVE = 5, // Each plane is stored into a DmaBuf. Why is STORAGE_NATIVE a more appropriate name than STORAGE_DMABUFS? It seems less specific. Are there cases where this is used with non-DMA buffers? https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... media/base/video_frame.h:340: int DmabufFd(size_t plane) const; If we do not want to be as specific as saying "DMA buffers" in the enum value above, should we also make the name of this method more general?
The CQ bit was checked by mcasas@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: Try jobs failed on following builders: mac_chromium_compile_dbg_ng on master.tryserver.chromium.mac (JOB_FAILED, http://build.chromium.org/p/tryserver.chromium.mac/builders/mac_chromium_comp...)
Description was changed from ========== Rename functions in video frame to comply with Style Guide BUG=None ========== to ========== Rename functions in video frame to comply with Style Guide BUG=None CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel ==========
https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h File media/base/video_frame.h (right): https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... media/base/video_frame.h:66: STORAGE_NATIVE = 5, // Each plane is stored into a DmaBuf. On 2017/03/30 17:55:44, chfremer wrote: > Why is STORAGE_NATIVE a more appropriate name than STORAGE_DMABUFS? It seems > less specific. Are there cases where this is used with non-DMA buffers? Updated the name as per comment mentioned, but yes your right STORAGE_DMABUFS looks better as i am not aware of any cases where this is used with non-DMA buffers. https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... media/base/video_frame.h:340: int DmabufFd(size_t plane) const; On 2017/03/30 17:55:44, chfremer wrote: > If we do not want to be as specific as saying "DMA buffers" in the enum value > above, should we also make the name of this method more general? Changed above as i am not aware of any Non DMA buffer cases where it might be used.
The CQ bit was checked by uzair.jaleel@samsung.com to run a CQ dry run
The CQ bit was unchecked by uzair.jaleel@samsung.com
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: No L-G-T-M from a valid reviewer yet. CQ run can only be started once the patch has received an L-G-T-M from a full committer. Even if an L-G-T-M may have been provided, it was from a non-committer,_not_ a full super star committer. Committers are members of the group "project-chromium-committers". Note that this has nothing to do with OWNERS files.
On 2017/03/31 10:09:19, Uzair wrote: > https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h > File media/base/video_frame.h (right): > > https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... > media/base/video_frame.h:66: STORAGE_NATIVE = 5, // Each plane is stored into a > DmaBuf. > On 2017/03/30 17:55:44, chfremer wrote: > > Why is STORAGE_NATIVE a more appropriate name than STORAGE_DMABUFS? It seems > > less specific. Are there cases where this is used with non-DMA buffers? > > Updated the name as per comment mentioned, but yes your right STORAGE_DMABUFS > looks better as i am not aware of any cases where this is used with non-DMA > buffers. > > https://codereview.chromium.org/2781283002/diff/1/media/base/video_frame.h#ne... > media/base/video_frame.h:340: int DmabufFd(size_t plane) const; > On 2017/03/30 17:55:44, chfremer wrote: > > If we do not want to be as specific as saying "DMA buffers" in the enum value > > above, should we also make the name of this method more general? > > Changed above as i am not aware of any Non DMA buffer cases where it might be > used. PTAL Thanks
lgtm % one optional suggestion https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.h File media/base/video_frame.h (right): https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.... media/base/video_frame.h:66: STORAGE_DMABUFS = 5, // Each plane is stored into a DmaBuf. I chatted with mcasas@ and it seems that his suggestion to rename this to STORAGE_NATIVE was based on the idea of using this same enum value for both DMA buffers on Linux and CVPixelBuffers on Mac (which currently use STORAGE_UNOWNED_MEMORY). Maybe, instead of dropping the TODO here, we could reformulate it to express that.
Done. PTAL https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.h File media/base/video_frame.h (right): https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.... media/base/video_frame.h:66: STORAGE_DMABUFS = 5, // Each plane is stored into a DmaBuf. On 2017/03/31 17:50:21, chfremer wrote: > I chatted with mcasas@ and it seems that his suggestion to rename this to > STORAGE_NATIVE was based on the idea of using this same enum value for both DMA > buffers on Linux and CVPixelBuffers on Mac (which currently use > STORAGE_UNOWNED_MEMORY). > > Maybe, instead of dropping the TODO here, we could reformulate it to express > that. Done.
On 2017/04/03 04:17:40, Uzair wrote: > Done. > > PTAL > > https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.h > File media/base/video_frame.h (right): > > https://codereview.chromium.org/2781283002/diff/20001/media/base/video_frame.... > media/base/video_frame.h:66: STORAGE_DMABUFS = 5, // Each plane is stored into > a DmaBuf. > On 2017/03/31 17:50:21, chfremer wrote: > > I chatted with mcasas@ and it seems that his suggestion to rename this to > > STORAGE_NATIVE was based on the idea of using this same enum value for both > DMA > > buffers on Linux and CVPixelBuffers on Mac (which currently use > > STORAGE_UNOWNED_MEMORY). > > > > Maybe, instead of dropping the TODO here, we could reformulate it to express > > that. > > Done. Dear Reviewers, PTAL
lgtm
The CQ bit was checked by mcasas@chromium.org to run a CQ dry run
Dry run: CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Dry run: Try jobs failed on following builders: mac_chromium_compile_dbg_ng on master.tryserver.chromium.mac (JOB_FAILED, http://build.chromium.org/p/tryserver.chromium.mac/builders/mac_chromium_comp...)
The CQ bit was checked by uzair.jaleel@samsung.com
The patchset sent to the CQ was uploaded after l-g-t-m from chfremer@chromium.org, mcasas@chromium.org Link to the patchset: https://codereview.chromium.org/2781283002/#ps60001 (title: "Fixed compilation errors for MAC")
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Try jobs failed on following builders: chromium_presubmit on master.tryserver.chromium.linux (JOB_FAILED, http://build.chromium.org/p/tryserver.chromium.linux/builders/chromium_presub...)
On 2017/04/05 04:37:51, commit-bot: I haz the power wrote: > Try jobs failed on following builders: > chromium_presubmit on master.tryserver.chromium.linux (JOB_FAILED, > http://build.chromium.org/p/tryserver.chromium.linux/builders/chromium_presub...) Dear reviewers There was build error which was fixed. Please review media/cast/sender/h264_vt_encoder_unittest.cc Thanks
Description was changed from ========== Rename functions in video frame to comply with Style Guide BUG=None CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel ========== to ========== Rename functions in video frame to comply with Style Guide BUG=None CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel ==========
uzair.jaleel@samsung.com changed reviewers: + hubbe@chromium.org
On 2017/04/05 07:52:35, Uzair wrote: > On 2017/04/05 04:37:51, commit-bot: I haz the power wrote: > > Try jobs failed on following builders: > > chromium_presubmit on master.tryserver.chromium.linux (JOB_FAILED, > > > http://build.chromium.org/p/tryserver.chromium.linux/builders/chromium_presub...) > > Dear reviewers > > There was build error which was fixed. > Please review media/cast/sender/h264_vt_encoder_unittest.cc > > Thanks In general, there is no need to ask reviewers to re-confirm their sign-offs if the changes since their sign-off are canonical, as is the case here. The reason the commit failed is that neither mcasas@ nor myself are OWNERs of the files touched in this CL.
On 2017/04/05 16:23:27, chfremer wrote: > On 2017/04/05 07:52:35, Uzair wrote: > > On 2017/04/05 04:37:51, commit-bot: I haz the power wrote: > > > Try jobs failed on following builders: > > > chromium_presubmit on master.tryserver.chromium.linux (JOB_FAILED, > > > > > > http://build.chromium.org/p/tryserver.chromium.linux/builders/chromium_presub...) > > > > Dear reviewers > > > > There was build error which was fixed. > > Please review media/cast/sender/h264_vt_encoder_unittest.cc > > > > Thanks > > In general, there is no need to ask reviewers to re-confirm their sign-offs if > the changes since > their sign-off are canonical, as is the case here. > > The reason the commit failed is that neither mcasas@ nor myself are OWNERs of > the files touched in this CL. Dear Hubbe, PTAL Thanks
lgtm
The CQ bit was checked by uzair.jaleel@samsung.com
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
The CQ bit was unchecked by commit-bot@chromium.org
Try jobs failed on following builders: linux_optional_gpu_tests_rel on master.tryserver.chromium.linux (JOB_FAILED, http://build.chromium.org/p/tryserver.chromium.linux/builders/linux_optional_...)
On 2017/04/07 06:42:21, commit-bot: I haz the power wrote: > Try jobs failed on following builders: > linux_optional_gpu_tests_rel on master.tryserver.chromium.linux (JOB_FAILED, > http://build.chromium.org/p/tryserver.chromium.linux/builders/linux_optional_...) Hi , Not sure why webgl conformance test is failing with this patch Any input would be helpful Thanks
On 2017/04/07 16:08:32, Uzair wrote: > On 2017/04/07 06:42:21, commit-bot: I haz the power wrote: > > Try jobs failed on following builders: > > linux_optional_gpu_tests_rel on master.tryserver.chromium.linux (JOB_FAILED, > > > http://build.chromium.org/p/tryserver.chromium.linux/builders/linux_optional_...) > > Hi , > > Not sure why webgl conformance test is failing with this patch > > Any input would be helpful > > Thanks I don't think it fails because of the changes in this CL. Looking at [1] it seems like it is currently in a bad state. I recommend we wait a bit to see if it clears, or maybe try to find a sheriff and ask about it. [1] https://build.chromium.org/p/tryserver.chromium.linux/builders/linux_optional...
The CQ bit was checked by uzair.jaleel@samsung.com
CQ is trying da patch. Follow status at https://chromium-cq-status.appspot.com/v2/patch-status/codereview.chromium.or...
CQ is committing da patch. Bot data: {"patchset_id": 60001, "attempt_start_ts": 1491742466653900, "parent_rev": "eb78b6f967fa965906d28a29190a89cce95190ec", "commit_rev": "46944f80bfc35a8589514f8b8c9d895c21e17f2a"}
Message was sent while issue was closed.
Description was changed from ========== Rename functions in video frame to comply with Style Guide BUG=None CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel ========== to ========== Rename functions in video frame to comply with Style Guide BUG=None CQ_INCLUDE_TRYBOTS=master.tryserver.chromium.android:android_optional_gpu_tests_rel;master.tryserver.chromium.linux:linux_optional_gpu_tests_rel;master.tryserver.chromium.mac:mac_optional_gpu_tests_rel;master.tryserver.chromium.win:win_optional_gpu_tests_rel Review-Url: https://codereview.chromium.org/2781283002 Cr-Commit-Position: refs/heads/master@{#463153} Committed: https://chromium.googlesource.com/chromium/src/+/46944f80bfc35a8589514f8b8c9d... ==========
Message was sent while issue was closed.
Committed patchset #4 (id:60001) as https://chromium.googlesource.com/chromium/src/+/46944f80bfc35a8589514f8b8c9d... |