Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(526)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.h

Issue 2665583002: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. (Closed)
Patch Set: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.h
diff --git a/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.h b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.h
new file mode 100644
index 0000000000000000000000000000000000000000..84f3c573814ab0c694b3a345f9d51649d8e5ae2a
--- /dev/null
+++ b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.h
@@ -0,0 +1,26 @@
+// Copyright 2016 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+#ifndef PaymentAppRequestConversion_h
+#define PaymentAppRequestConversion_h
+
+#include "modules/payments/PaymentAppRequest.h"
+#include "wtf/Allocator.h"
+
+namespace blink {
+
+class ScriptState;
+struct WebPaymentAppRequest;
+
+class MODULES_EXPORT PaymentAppRequestConversion {
+ STATIC_ONLY(PaymentAppRequestConversion);
+
+ public:
+ static PaymentAppRequest toPaymentAppRequest(ScriptState*,
+ const WebPaymentAppRequest&);
+};
+
+} // namespace blink
+
+#endif // PaymentAppRequestConversion_h

Powered by Google App Engine
This is Rietveld 408576698