Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(120)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.cpp

Issue 2665583002: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. (Closed)
Patch Set: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.cpp
diff --git a/third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversion.cpp b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.cpp
similarity index 82%
rename from third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversion.cpp
rename to third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.cpp
index b302ae4b51d1328bfbe05d46ab1afdee7a37c139..abe0dd5bfc87237d34009d5a6fb62a45ba1a9ac0 100644
--- a/third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversion.cpp
+++ b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversion.cpp
@@ -2,16 +2,16 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#include "modules/payments/PaymentAppRequestDataConversion.h"
+#include "modules/payments/PaymentAppRequestConversion.h"
#include "bindings/core/v8/ScriptState.h"
#include "bindings/core/v8/ToV8.h"
-#include "modules/payments/PaymentAppRequestData.h"
+#include "modules/payments/PaymentAppRequest.h"
#include "modules/payments/PaymentCurrencyAmount.h"
#include "modules/payments/PaymentDetailsModifier.h"
#include "modules/payments/PaymentItem.h"
#include "modules/payments/PaymentMethodData.h"
-#include "public/platform/modules/payments/WebPaymentAppRequestData.h"
+#include "public/platform/modules/payments/WebPaymentAppRequest.h"
#include "public/platform/modules/payments/WebPaymentMethodData.h"
namespace blink {
@@ -83,24 +83,24 @@ PaymentMethodData toPaymentMethodData(
} // namespace
-PaymentAppRequestData PaymentAppRequestDataConversion::toPaymentAppRequestData(
+PaymentAppRequest PaymentAppRequestConversion::toPaymentAppRequest(
ScriptState* scriptState,
- const WebPaymentAppRequestData& webData) {
- PaymentAppRequestData data;
+ const WebPaymentAppRequest& webAppRequest) {
+ PaymentAppRequest appRequest;
- data.setOrigin(webData.origin);
+ appRequest.setOrigin(webAppRequest.origin);
HeapVector<PaymentMethodData> methodData;
- for (const auto& md : webData.methodData) {
+ for (const auto& md : webAppRequest.methodData) {
methodData.push_back(toPaymentMethodData(scriptState, md));
}
- data.setMethodData(methodData);
- data.setTotal(toPaymentItem(webData.total));
+ appRequest.setMethodData(methodData);
+ appRequest.setTotal(toPaymentItem(webAppRequest.total));
HeapVector<PaymentDetailsModifier> modifiers;
- for (const auto& modifier : webData.modifiers) {
+ for (const auto& modifier : webAppRequest.modifiers) {
modifiers.push_back(toPaymentDetailsModifier(scriptState, modifier));
}
- data.setOptionId(webData.optionId);
- return data;
+ appRequest.setOptionId(webAppRequest.optionId);
+ return appRequest;
}
} // namespace blink

Powered by Google App Engine
This is Rietveld 408576698