Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(636)

Unified Diff: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversionTest.cpp

Issue 2665583002: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. (Closed)
Patch Set: PaymentApp: Rename PaymentAppRequestData to PaymentAppRequest. Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/modules/payments/PaymentAppRequestConversionTest.cpp
diff --git a/third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversionTest.cpp b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversionTest.cpp
similarity index 83%
rename from third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversionTest.cpp
rename to third_party/WebKit/Source/modules/payments/PaymentAppRequestConversionTest.cpp
index 8587fb9b019a26f3f6dc5f6bf3e1396829237297..612217d56bf0a62ded98cef8edcc929c5a3ad6b8 100644
--- a/third_party/WebKit/Source/modules/payments/PaymentAppRequestDataConversionTest.cpp
+++ b/third_party/WebKit/Source/modules/payments/PaymentAppRequestConversionTest.cpp
@@ -2,13 +2,13 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#include "modules/payments/PaymentAppRequestDataConversion.h"
+#include "modules/payments/PaymentAppRequestConversion.h"
#include "bindings/core/v8/ScriptState.h"
#include "bindings/core/v8/ScriptValue.h"
#include "bindings/core/v8/V8Binding.h"
#include "bindings/core/v8/V8BindingForTesting.h"
-#include "public/platform/modules/payments/WebPaymentAppRequestData.h"
+#include "public/platform/modules/payments/WebPaymentAppRequest.h"
#include "testing/gmock/include/gmock/gmock.h"
#include "testing/gtest/include/gtest/gtest.h"
@@ -31,8 +31,8 @@ static WebPaymentMethodData createWebPaymentMethodDataForTest() {
return webMethodData;
}
-static WebPaymentAppRequestData createWebPaymentAppRequestDataForTest() {
- WebPaymentAppRequestData webData;
+static WebPaymentAppRequest createWebPaymentAppRequestForTest() {
+ WebPaymentAppRequest webData;
webData.origin = WebString::fromUTF8("https://example.com");
Vector<WebPaymentMethodData> methodData;
methodData.push_back(createWebPaymentMethodDataForTest());
@@ -42,12 +42,11 @@ static WebPaymentAppRequestData createWebPaymentAppRequestDataForTest() {
return webData;
}
-TEST(PaymentAppRequestDataConversionTest, ToPaymentAppRequestData) {
+TEST(PaymentAppRequestConversionTest, ToPaymentAppRequest) {
V8TestingScope scope;
- WebPaymentAppRequestData webData = createWebPaymentAppRequestDataForTest();
- PaymentAppRequestData data =
- PaymentAppRequestDataConversion::toPaymentAppRequestData(
- scope.getScriptState(), webData);
+ WebPaymentAppRequest webData = createWebPaymentAppRequestForTest();
+ PaymentAppRequest data = PaymentAppRequestConversion::toPaymentAppRequest(
+ scope.getScriptState(), webData);
ASSERT_TRUE(data.hasMethodData());
ASSERT_EQ(1UL, data.methodData().size());

Powered by Google App Engine
This is Rietveld 408576698