Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(259)

Unified Diff: media/capture/mojo/video_capture_types.mojom

Issue 2609863004: Pass camera facing to WebKit (Closed)
Patch Set: fix trybot errors Created 3 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: media/capture/mojo/video_capture_types.mojom
diff --git a/media/capture/mojo/video_capture_types.mojom b/media/capture/mojo/video_capture_types.mojom
index d020527b0e114c3daf5dc842852b08db4bb91c35..ce8fe83fad8b8767cd4744f0353856e48eb39247 100644
--- a/media/capture/mojo/video_capture_types.mojom
+++ b/media/capture/mojo/video_capture_types.mojom
@@ -26,6 +26,19 @@ enum VideoPixelStorage {
GPUMEMORYBUFFER
};
+// TODO(hta): crbug:680396. Consider to rename it to FacingMode.
hta - Chromium 2017/01/12 19:36:41 The convention for TODO is TODO(name of person who
shenghao 2017/01/13 11:09:34 Deleted
+enum VideoFacingMode {
+ // The source is facing toward the user (a self-view camera).
+ USER,
+ // The source is facing away from the user (viewing the environment).
+ ENVIRONMENT,
+ // The source is facing to the left of the user.
+ LEFT,
+ // The source is facing to the right of the user.
+ RIGHT,
+ NONE
+};
hta - Chromium 2017/01/12 19:36:41 I don't understand what value this Mojom definitio
jochen (gone - plz use gerrit) 2017/01/13 08:47:09 we should remove the other enum, and just use the
shenghao 2017/01/13 11:09:34 After looking at hta@'s CL (https://codereview.chr
shenghao 2017/01/13 11:09:34 Deleted
+
enum VideoCaptureApi {
LINUX_V4L2_SINGLE_PLANE,
WIN_MEDIA_FOUNDATION,

Powered by Google App Engine
This is Rietveld 408576698