Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(670)

Unified Diff: sdk/lib/io/timer_impl.dart

Issue 12793003: Rename Timer.repeating to Timer.periodic. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/io/timer_impl.dart
diff --git a/sdk/lib/io/timer_impl.dart b/sdk/lib/io/timer_impl.dart
index cf92388ccd92bcf80f70119f2a497adf7184ed1f..107dabaac2eb301667dc541128f209531c89ebbc 100644
--- a/sdk/lib/io/timer_impl.dart
+++ b/sdk/lib/io/timer_impl.dart
@@ -32,7 +32,7 @@ class _Timer implements Timer {
return _createTimer(callback, milliSeconds, false);
}
- factory _Timer.repeating(int milliSeconds, void callback(Timer timer)) {
+ factory _Timer.periodic(int milliSeconds, void callback(Timer timer)) {
return _createTimer(callback, milliSeconds, true);
}
@@ -193,7 +193,7 @@ class _Timer implements Timer {
_getTimerFactoryClosure() {
return (int milliSeconds, void callback(Timer timer), bool repeating) {
if (repeating) {
- return new _Timer.repeating(milliSeconds, callback);
+ return new _Timer.periodic(milliSeconds, callback);
}
return new _Timer(milliSeconds, callback);
};

Powered by Google App Engine
This is Rietveld 408576698