Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1466)

Unified Diff: sdk/lib/async/timer.dart

Issue 12793003: Rename Timer.repeating to Timer.periodic. (Closed) Base URL: https://dart.googlecode.com/svn/branches/bleeding_edge/dart
Patch Set: Created 7 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: sdk/lib/async/timer.dart
diff --git a/sdk/lib/async/timer.dart b/sdk/lib/async/timer.dart
index 6bfbfbcf493565281a49eb8662ce2e21f1b00247..d4199a3ba7354b9abf1d53a11478897dc4435b11 100644
--- a/sdk/lib/async/timer.dart
+++ b/sdk/lib/async/timer.dart
@@ -36,8 +36,8 @@ abstract class Timer {
* The [callback] is invoked repeatedly with [duration] intervals until
* canceled. A negative duration is treated similar to a duration of 0.
*/
- external factory Timer.repeating(Duration duration,
- void callback(Timer timer));
+ external factory Timer.periodic(Duration duration,
+ void callback(Timer timer));
/**
* Runs the given [callback] asynchronously as soon as possible.

Powered by Google App Engine
This is Rietveld 408576698