Description[es6] Map/Set size getter should have "get size" name
This reverts commit d5565c1f689b2953d92abd350529363f04f90fcd.
Getter and setter function names in ES6 are defined as "get foo" and
"set foo".
This also moves the logic for handling symbols from runtime-function.cc
to v8natives.js.
BUG=None
LOG=N
R=adamk@chromium.org
Committed: https://crrev.com/2279dfe7890f4cbe63f1ee9adb290a533d9a2c20
Cr-Commit-Position: refs/heads/master@{#28050}
Patch Set 1 #Patch Set 2 : Move the string flattening to v8natives.js #Patch Set 3 : Moved the flatten back to the runtime but restructured the code slightly #
Total comments: 1
Patch Set 4 : NameToFunctionName might allocate now so we need to be careful about execution order #
Total comments: 1
Patch Set 5 : cleanup #Patch Set 6 : Remove comment #Patch Set 7 : Implement ES6 SetFunctionName correctly #Patch Set 8 : Use IS_UNDEFINED instead #
Messages
Total messages: 31 (6 generated)
|