Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(760)

Unified Diff: Source/core/dom/ScriptRunner.cpp

Issue 937883003: Rename CancellableTaskFactory::task() for clarity. (Closed) Base URL: https://chromium.googlesource.com/chromium/blink.git@master
Patch Set: Rebase Created 5 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « no previous file | Source/core/html/parser/HTMLParserScheduler.cpp » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: Source/core/dom/ScriptRunner.cpp
diff --git a/Source/core/dom/ScriptRunner.cpp b/Source/core/dom/ScriptRunner.cpp
index 7987bf5098300901c9c579c33f4ad0dc081ca6e3..612aaf873cc44c771c38b4b4c59c113313235541 100644
--- a/Source/core/dom/ScriptRunner.cpp
+++ b/Source/core/dom/ScriptRunner.cpp
@@ -225,7 +225,7 @@ void ScriptRunner::postTaskIfOneIsNotAlreadyInFlight()
return;
// FIXME: Rename task() so that it's obvious it cancels any pending task.
- Platform::current()->currentThread()->scheduler()->postLoadingTask(FROM_HERE, m_executeScriptsTaskFactory.task());
+ Platform::current()->currentThread()->scheduler()->postLoadingTask(FROM_HERE, m_executeScriptsTaskFactory.cancelAndCreate());
}
DEFINE_TRACE(ScriptRunner)
« no previous file with comments | « no previous file | Source/core/html/parser/HTMLParserScheduler.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698