Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(2073)

Unified Diff: Source/modules/push_messaging/PushSubscription.idl

Issue 841333002: Push API: rename registration to subscription. (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: Use https in the spec link. Created 5 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: Source/modules/push_messaging/PushSubscription.idl
diff --git a/Source/modules/push_messaging/PushRegistration.idl b/Source/modules/push_messaging/PushSubscription.idl
similarity index 57%
rename from Source/modules/push_messaging/PushRegistration.idl
rename to Source/modules/push_messaging/PushSubscription.idl
index 243215d9fc20fb200d414d64097ca52d7a21f3df..5dc925b3540fabea16d3f83a5cf4583e4a4ac031 100644
--- a/Source/modules/push_messaging/PushRegistration.idl
+++ b/Source/modules/push_messaging/PushSubscription.idl
@@ -2,13 +2,13 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-// http://www.w3.org/TR/push-api/#pushregistration-interface
+// http://w3c.github.io/push-api/#pushsubscription-interface
[
GarbageCollected,
RuntimeEnabled=PushMessaging,
-] interface PushRegistration {
+] interface PushSubscription {
readonly attribute DOMString endpoint;
- readonly attribute DOMString registrationId;
- [CallWith=ScriptState] Promise<boolean> unregister();
+ readonly attribute DOMString subscriptionId;
+ [CallWith=ScriptState] Promise<boolean> unsubscribe();
};
« no previous file with comments | « Source/modules/push_messaging/PushSubscription.cpp ('k') | Source/modules/push_messaging/PushSubscriptionCallbacks.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698