Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(138)

Side by Side Diff: Source/modules/push_messaging/PushSubscription.idl

Issue 841333002: Push API: rename registration to subscription. (Closed) Base URL: svn://svn.chromium.org/blink/trunk
Patch Set: Use https in the spec link. Created 5 years, 11 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View unified diff | Download patch | Annotate | Revision Log
OLDNEW
1 // Copyright 2014 The Chromium Authors. All rights reserved. 1 // Copyright 2014 The Chromium Authors. All rights reserved.
2 // Use of this source code is governed by a BSD-style license that can be 2 // Use of this source code is governed by a BSD-style license that can be
3 // found in the LICENSE file. 3 // found in the LICENSE file.
4 4
5 // http://www.w3.org/TR/push-api/#pushregistration-interface 5 // http://w3c.github.io/push-api/#pushsubscription-interface
6 6
7 [ 7 [
8 GarbageCollected, 8 GarbageCollected,
9 RuntimeEnabled=PushMessaging, 9 RuntimeEnabled=PushMessaging,
10 ] interface PushRegistration { 10 ] interface PushSubscription {
11 readonly attribute DOMString endpoint; 11 readonly attribute DOMString endpoint;
12 readonly attribute DOMString registrationId; 12 readonly attribute DOMString subscriptionId;
13 [CallWith=ScriptState] Promise<boolean> unregister(); 13 [CallWith=ScriptState] Promise<boolean> unsubscribe();
14 }; 14 };
OLDNEW
« no previous file with comments | « Source/modules/push_messaging/PushSubscription.cpp ('k') | Source/modules/push_messaging/PushSubscriptionCallbacks.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698