Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(488)

Unified Diff: crypto/rsa_private_key.h

Issue 7491061: Rename CRYPTO_API to CRYPTO_EXPORT. (Closed) Base URL: svn://svn.chromium.org/chrome/trunk/src/
Patch Set: Created 9 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « crypto/openpgp_symmetric_encryption.h ('k') | crypto/secure_hash.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: crypto/rsa_private_key.h
===================================================================
--- crypto/rsa_private_key.h (revision 95624)
+++ crypto/rsa_private_key.h (working copy)
@@ -23,7 +23,7 @@
#include <vector>
#include "base/basictypes.h"
-#include "crypto/crypto_api.h"
+#include "crypto/crypto_export.h"
#if defined(OS_WIN)
#include "crypto/scoped_capi_types.h"
@@ -171,7 +171,7 @@
// Encapsulates an RSA private key. Can be used to generate new keys, export
// keys to other formats, or to extract a public key.
// TODO(hclam): This class should be ref-counted so it can be reused easily.
-class CRYPTO_API RSAPrivateKey {
+class CRYPTO_EXPORT RSAPrivateKey {
public:
~RSAPrivateKey();
« no previous file with comments | « crypto/openpgp_symmetric_encryption.h ('k') | crypto/secure_hash.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698