Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(770)

Unified Diff: components/variations/metrics_util.h

Issue 49753002: RAPPOR implementation (Closed) Base URL: https://chromium.googlesource.com/chromium/src.git@master
Patch Set: Created 6 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: components/variations/metrics_util.h
diff --git a/components/variations/metrics_util.h b/components/variations/metrics_util.h
index b331d4eaf1f3e9d252398c5180c0f1319c818341..f0c42daa2bb7cc5fb83352d713f15d11318241ba 100644
--- a/components/variations/metrics_util.h
+++ b/components/variations/metrics_util.h
@@ -15,6 +15,10 @@ namespace metrics {
// uniquely identifying field trial names and group names.
uint32 HashName(const std::string& name);
Ilya Sherman 2014/02/12 23:25:59 nit: This method should probably be renamed to som
Steven Holte 2014/02/13 05:11:12 I'd rather leave that for a more focused cleanup o
Ilya Sherman 2014/02/13 23:23:08 You're welcome to split off the cleanup to a separ
+// Computes a uint64 hash of a given string based on its MD5 hash. Suitable for
+// metric names.
+uint64 HashMetricName(const std::string& name);
+
} // namespace metrics
#endif // COMPONENTS_VARIATIONS_METRICS_UTIL_H_

Powered by Google App Engine
This is Rietveld 408576698