Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(431)

Unified Diff: src/lithium-inl.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/lithium-codegen.cc ('k') | src/liveedit.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/lithium-inl.h
diff --git a/src/lithium-inl.h b/src/lithium-inl.h
index 5e5084f176ec7fcc7138e4399e33b3e0c066857b..36e166e9260c4a0fe2ed562636d7fec698ff266a 100644
--- a/src/lithium-inl.h
+++ b/src/lithium-inl.h
@@ -38,7 +38,7 @@ bool TempIterator::Done() { return current_ >= limit_; }
LOperand* TempIterator::Current() {
- ASSERT(!Done());
+ DCHECK(!Done());
return instr_->TempAt(current_);
}
@@ -64,8 +64,8 @@ bool InputIterator::Done() { return current_ >= limit_; }
LOperand* InputIterator::Current() {
- ASSERT(!Done());
- ASSERT(instr_->InputAt(current_) != NULL);
+ DCHECK(!Done());
+ DCHECK(instr_->InputAt(current_) != NULL);
return instr_->InputAt(current_);
}
@@ -95,10 +95,10 @@ bool UseIterator::Done() {
LOperand* UseIterator::Current() {
- ASSERT(!Done());
+ DCHECK(!Done());
LOperand* result = input_iterator_.Done() ? env_iterator_.Current()
: input_iterator_.Current();
- ASSERT(result != NULL);
+ DCHECK(result != NULL);
return result;
}
« no previous file with comments | « src/lithium-codegen.cc ('k') | src/liveedit.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698