Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(36)

Unified Diff: src/lithium-codegen.cc

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/lithium-allocator-inl.h ('k') | src/lithium-inl.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/lithium-codegen.cc
diff --git a/src/lithium-codegen.cc b/src/lithium-codegen.cc
index b13458a6174eec3667179d7e31593961bba7e843..8b6444db58b8831a5aa467d9f1a3ed36fe2d7f48 100644
--- a/src/lithium-codegen.cc
+++ b/src/lithium-codegen.cc
@@ -56,7 +56,7 @@ LCodeGenBase::LCodeGenBase(LChunk* chunk,
bool LCodeGenBase::GenerateBody() {
- ASSERT(is_generating());
+ DCHECK(is_generating());
bool emit_instructions = true;
LCodeGen* codegen = static_cast<LCodeGen*>(this);
for (current_instruction_ = 0;
@@ -168,7 +168,7 @@ static void AddWeakObjectToCodeDependency(Isolate* isolate,
void LCodeGenBase::RegisterWeakObjectsInOptimizedCode(Handle<Code> code) {
- ASSERT(code->is_optimized_code());
+ DCHECK(code->is_optimized_code());
ZoneList<Handle<Map> > maps(1, zone());
ZoneList<Handle<JSObject> > objects(1, zone());
ZoneList<Handle<Cell> > cells(1, zone());
« no previous file with comments | « src/lithium-allocator-inl.h ('k') | src/lithium-inl.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698