Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(111)

Unified Diff: src/compiler/linkage-impl.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/linkage.cc ('k') | src/compiler/node.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/linkage-impl.h
diff --git a/src/compiler/linkage-impl.h b/src/compiler/linkage-impl.h
index 7159bde59b0d64efdaf4d91b11c83376a81c4838..212a622ac082e475db1befcf991896ce68778eb2 100644
--- a/src/compiler/linkage-impl.h
+++ b/src/compiler/linkage-impl.h
@@ -12,7 +12,7 @@ namespace compiler {
class LinkageHelper {
public:
static LinkageLocation TaggedStackSlot(int index) {
- ASSERT(index < 0);
+ DCHECK(index < 0);
return LinkageLocation(kMachineTagged, index);
}
@@ -96,7 +96,7 @@ class LinkageHelper {
TaggedRegisterLocation(LinkageTraits::ReturnValue2Reg());
}
- ASSERT_LE(return_count, 2);
+ DCHECK_LE(return_count, 2);
locations[index++] = UnconstrainedRegister(kMachineTagged); // CEntryStub
« no previous file with comments | « src/compiler/linkage.cc ('k') | src/compiler/node.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698