Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1064)

Unified Diff: src/compiler/node.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/compiler/linkage-impl.h ('k') | src/compiler/node.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/compiler/node.h
diff --git a/src/compiler/node.h b/src/compiler/node.h
index be6adfe5f7398eb2363cfe4468ec5d5419812e73..ddca510a0e902c2a00c6bd43abbfca26bec0e491 100644
--- a/src/compiler/node.h
+++ b/src/compiler/node.h
@@ -27,7 +27,7 @@ class NodeData {
void set_op(Operator* op) { op_ = op; }
IrOpcode::Value opcode() const {
- ASSERT(op_->opcode() <= IrOpcode::kLast);
+ DCHECK(op_->opcode() <= IrOpcode::kLast);
return static_cast<IrOpcode::Value>(op_->opcode());
}
« no previous file with comments | « src/compiler/linkage-impl.h ('k') | src/compiler/node.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698