Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(885)

Unified Diff: src/store-buffer.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/spaces-inl.h ('k') | src/store-buffer.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/store-buffer.h
diff --git a/src/store-buffer.h b/src/store-buffer.h
index 9101c0eb892435d2ba07950d6906416d1fc7610b..de7be0e34ea79b90248ac660ce2d3a430f700fc2 100644
--- a/src/store-buffer.h
+++ b/src/store-buffer.h
@@ -81,8 +81,8 @@ class StoreBuffer {
Object*** Start() { return reinterpret_cast<Object***>(old_start_); }
Object*** Top() { return reinterpret_cast<Object***>(old_top_); }
void SetTop(Object*** top) {
- ASSERT(top >= Start());
- ASSERT(top <= Limit());
+ DCHECK(top >= Start());
+ DCHECK(top <= Limit());
old_top_ = reinterpret_cast<Address*>(top);
}
« no previous file with comments | « src/spaces-inl.h ('k') | src/store-buffer.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698