Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(741)

Unified Diff: src/log-utils.h

Issue 430503007: Rename ASSERT* to DCHECK*. (Closed) Base URL: https://v8.googlecode.com/svn/branches/bleeding_edge
Patch Set: REBASE and fixes Created 6 years, 4 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « src/log.cc ('k') | src/log-utils.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: src/log-utils.h
diff --git a/src/log-utils.h b/src/log-utils.h
index 451ffaa24b4a701c732735ea9d5f5745b6de5722..ef285e6d68c6dc8e4addd893f5af0220e40b279c 100644
--- a/src/log-utils.h
+++ b/src/log-utils.h
@@ -103,9 +103,9 @@ class Log {
// Implementation of writing to a log file.
int WriteToFile(const char* msg, int length) {
- ASSERT(output_handle_ != NULL);
+ DCHECK(output_handle_ != NULL);
size_t rv = fwrite(msg, 1, length, output_handle_);
- ASSERT(static_cast<size_t>(length) == rv);
+ DCHECK(static_cast<size_t>(length) == rv);
USE(rv);
fflush(output_handle_);
return length;
« no previous file with comments | « src/log.cc ('k') | src/log-utils.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698