DescriptionUse Traversal<>::firstChild() instead of firstWithin() when iterating over children
Use Traversal<>::firstChild() instead of firstWithin() when iterating over
children. It makes it clearer that we are only iterating over the children and
not traversing the descendants.
There is no behavior change since firstChild() is equivalent to firstWithin()
for ElementTraversal / Traversal<HTMLElement>. However, using firstChild()
improves readability a bit.
Committed: https://src.chromium.org/viewvc/blink?view=rev&revision=178819
Patch Set 1 #
Messages
Total messages: 5 (0 generated)
|