DescriptionRename variables in ContainerNode::checkForSiblingStyleChanges() for clarity
Rename variables in ContainerNode::checkForSiblingStyleChanges() for clarity
and also update comments.
Variables renaming:
- beforeChange / afterChange to nodeBeforeChange / nodeAfterChange to be clear
about the type (e.g. not necessary Element nodes)
- newFirstChild / newLastChild to firstChildElement / lastChildElement to be
clear that those are the first / last child _elements_.
- lastElementBeforeInsertion / firstElementAfterInsertion to
elementBeforeChange / elementAfterChange as the change is not necessarily an
insertion (e.g. could be a removal). The naming was confusing.
Also add an ASSERT(changeType != FinishedParsingChildren) assertion to enforce
the precondition explained in the comment for the corresponding scope.
There is no functional change in this CL to make it more easily reviewable.
This CL is purely about improving code readability / understandability.
R=esprehn@chromium.org
Committed: https://src.chromium.org/viewvc/blink?view=rev&revision=178055
Patch Set 1 #
Total comments: 5
Messages
Total messages: 8 (0 generated)
|