Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(133)

Issue 355843002: Rename style(bool) to styleOrFirstLineStyle(bool) (Closed)

Created:
6 years, 6 months ago by davve
Modified:
6 years, 5 months ago
CC:
aandrey+blink_chromium.org, apavlov+blink_chromium.org, blink-reviews, blink-reviews-rendering, caseq+blink_chromium.org, cbiesinger, devtools-reviews_chromium.org, eae+blinkwatch, eustas+blink_chromium.org, jchaffraix+rendering, leviw+renderwatch, loislo+blink_chromium.org, lushnikov+blink_chromium.org, malch+blink_chromium.org, paulirish+reviews_chromium.org, pdr., pfeldman+blink_chromium.org, rune+blink, sergeyv+blink_chromium.org, vsevik+blink_chromium.org, yurys+blink_chromium.org, zoltan1
Base URL:
https://chromium.googlesource.com/chromium/blink.git@master
Project:
blink
Visibility:
Public.

Description

Rename style(bool) to styleOrFirstLineStyle(bool) Having bool arguments to functions isn't ideal but a naming such as styleOrFirstLineStyle makes it obvious what's going on in most cases. This patch is preparation for moving inline definitions of firstLineStyle() and styleOrFirstLineStyle() to a separate header file so that RenderObject.h doesn't have to include StyleEngine.h (and in extension most of the style system). In turn, this also makes it easier to in the future remove the document.h include from RenderObject.h, further removing intra-dependendcies between header files in Blink. This is a mechanical change only. Minor clean-ups will follow.

Patch Set 1 #

Unified diffs Side-by-side diffs Delta from patch set Stats (+82 lines, -82 lines) Patch
M Source/core/inspector/InspectorCSSAgent.cpp View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/EllipsisBox.cpp View 3 chunks +5 lines, -5 lines 0 comments Download
M Source/core/rendering/InlineBox.h View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/InlineBox.cpp View 1 chunk +2 lines, -2 lines 0 comments Download
M Source/core/rendering/InlineFlowBox.h View 1 chunk +2 lines, -2 lines 0 comments Download
M Source/core/rendering/InlineFlowBox.cpp View 17 chunks +24 lines, -24 lines 0 comments Download
M Source/core/rendering/InlineTextBox.cpp View 8 chunks +8 lines, -8 lines 0 comments Download
M Source/core/rendering/RenderBR.cpp View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/RenderBlock.cpp View 5 chunks +5 lines, -5 lines 0 comments Download
M Source/core/rendering/RenderBlockLineLayout.cpp View 3 chunks +3 lines, -3 lines 0 comments Download
M Source/core/rendering/RenderDeprecatedFlexibleBox.cpp View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/RenderInline.cpp View 6 chunks +10 lines, -10 lines 0 comments Download
M Source/core/rendering/RenderObject.h View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/RenderObject.cpp View 2 chunks +2 lines, -2 lines 0 comments Download
M Source/core/rendering/RenderRubyRun.cpp View 1 chunk +3 lines, -3 lines 0 comments Download
M Source/core/rendering/RenderText.cpp View 1 chunk +1 line, -1 line 0 comments Download
M Source/core/rendering/RootInlineBox.cpp View 5 chunks +10 lines, -10 lines 0 comments Download
M Source/core/rendering/line/BreakingContextInlineHeaders.h View 2 chunks +2 lines, -2 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
davve
I'm testing the waters here. My objective is to reduce re-compilation when making changes to ...
6 years, 6 months ago (2014-06-25 14:16:58 UTC) #1
abarth-chromium
I'm not the correct reviewer for this change. You probably want esprehn or eseidel
6 years, 6 months ago (2014-06-25 19:48:19 UTC) #2
davve
6 years, 5 months ago (2014-06-27 11:46:45 UTC) #3
Message was sent while issue was closed.
Closing this since we're trying to head down another path in
https://codereview.chromium.org/351213002/

Powered by Google App Engine
This is Rietveld 408576698