Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(328)

Issue 340013: Fix crbug/24815. Changes affect profiler "lazy" mode used for V8 in Chromium. (Closed)

Created:
11 years, 1 month ago by mnaganov (inactive)
Modified:
9 years, 7 months ago
CC:
v8-dev
Visibility:
Public.

Description

Fix crbug/24815. Changes affect profiler "lazy" mode used for V8 in Chromium. - don't engage the processing thread of CPU profiling until the first time profiling is resumed, this saves us a thread allocation for the majority of users; - don't log shared libraries addresses: this is useless for JS-only profiling, and also consumes time on startup. Committed: http://code.google.com/p/v8/source/detail?r=3154

Patch Set 1 #

Total comments: 2

Patch Set 2 : Comments addressed #

Unified diffs Side-by-side diffs Delta from patch set Stats (+26 lines, -11 lines) Patch
src/log.cc View 1 5 chunks +24 lines, -8 lines 0 comments Download
test/cctest/test-log.cc View 1 chunk +2 lines, -3 lines 0 comments Download

Messages

Total messages: 3 (0 generated)
mnaganov (inactive)
11 years, 1 month ago (2009-10-27 21:32:57 UTC) #1
Søren Thygesen Gjesse
LGTM for solving http://crbug.com/24815 However I think the naming and effects of flags prof/prof_auto/prof_lazy should ...
11 years, 1 month ago (2009-10-28 08:51:10 UTC) #2
mnaganov (inactive)
11 years, 1 month ago (2009-10-28 09:12:08 UTC) #3
Thanks, Søren! I agree with you that we need to simplify those flags. I've
created http://code.google.com/p/v8/issues/detail?id=487 to track this issue.

On 2009/10/28 08:51:10, Søren Gjesse wrote:
> LGTM for solving http://crbug.com/24815
> 
> However I think the naming and effects of flags prof/prof_auto/prof_lazy
should
> be revised. Maybe some of this configuration can be moved to the API.
> 
> http://codereview.chromium.org/340013/diff/1/2
> File src/log.cc (right):
> 
> http://codereview.chromium.org/340013/diff/1/2#newcode250
> Line 250: : head_(0),
> Four space indent for :.
> 
> http://codereview.chromium.org/340013/diff/1/2#newcode263
> Line 263: if (!FLAG_prof_lazy) {
> This is a bit subtle, as the use of prof_lazy (which should be renamed) does
not
> necessarily imply that JavaScript only profiling is intended.

Powered by Google App Engine
This is Rietveld 408576698