Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(413)

Issue 2938853004: Rename ClosureClassMaps to ClosureDataLookup (Closed)

Created:
3 years, 6 months ago by Emily Fortuna
Modified:
3 years, 6 months ago
CC:
reviews_dartlang.org, Johnni Winther
Target Ref:
refs/heads/master
Visibility:
Public.

Description

Rename ClosureClassMaps to CLosureDataLookup (doing small tasks while I wait to talk to Siggi). BUG= R=sigmund@google.com Committed: https://github.com/dart-lang/sdk/commit/e6d7c0500c4403e4f26a13ecdd57b4ab7197ba30

Patch Set 1 #

Total comments: 10

Patch Set 2 : . #

Unified diffs Side-by-side diffs Delta from patch set Stats (+64 lines, -65 lines) Patch
M pkg/compiler/lib/src/closure.dart View 1 3 chunks +6 lines, -6 lines 0 comments Download
M pkg/compiler/lib/src/compiler.dart View 2 chunks +2 lines, -2 lines 0 comments Download
M pkg/compiler/lib/src/dump_info.dart View 1 chunk +1 line, -2 lines 0 comments Download
M pkg/compiler/lib/src/inferrer/builder.dart View 2 chunks +2 lines, -2 lines 0 comments Download
M pkg/compiler/lib/src/inferrer/builder_kernel.dart View 1 chunk +1 line, -1 line 0 comments Download
M pkg/compiler/lib/src/js_backend/element_strategy.dart View 1 chunk +1 line, -1 line 0 comments Download
M pkg/compiler/lib/src/js_emitter/code_emitter_task.dart View 1 chunk +1 line, -1 line 0 comments Download
M pkg/compiler/lib/src/js_emitter/program_builder/program_builder.dart View 3 chunks +3 lines, -3 lines 0 comments Download
M pkg/compiler/lib/src/js_emitter/runtime_type_generator.dart View 3 chunks +3 lines, -3 lines 0 comments Download
M pkg/compiler/lib/src/kernel/element_map.dart View 1 chunk +1 line, -1 line 0 comments Download
M pkg/compiler/lib/src/kernel/kernel_backend_strategy.dart View 3 chunks +4 lines, -4 lines 0 comments Download
M pkg/compiler/lib/src/ssa/builder.dart View 13 chunks +15 lines, -15 lines 0 comments Download
M pkg/compiler/lib/src/ssa/builder_kernel.dart View 13 chunks +15 lines, -15 lines 0 comments Download
M pkg/compiler/lib/src/ssa/graph_builder.dart View 2 chunks +2 lines, -2 lines 0 comments Download
M pkg/compiler/lib/src/ssa/kernel_ast_adapter.dart View 2 chunks +3 lines, -3 lines 0 comments Download
M pkg/compiler/lib/src/ssa/rasta_ssa_builder_task.dart View 1 chunk +1 line, -1 line 0 comments Download
M tests/compiler/dart2js/memory_compiler.dart View 1 chunk +1 line, -1 line 0 comments Download
M tests/compiler/dart2js/serialization/model_test_helper.dart View 1 chunk +2 lines, -2 lines 0 comments Download

Messages

Total messages: 9 (3 generated)
Emily Fortuna
3 years, 6 months ago (2017-06-14 21:02:57 UTC) #2
Siggi Cherem (dart-lang)
lgtm https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closure.dart File pkg/compiler/lib/src/closure.dart (right): https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closure.dart#newcode5 pkg/compiler/lib/src/closure.dart:5: library closureDataLookup; nit: the convention is to use ...
3 years, 6 months ago (2017-06-14 23:17:12 UTC) #3
Emily Fortuna
https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closure.dart File pkg/compiler/lib/src/closure.dart (right): https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closure.dart#newcode5 pkg/compiler/lib/src/closure.dart:5: library closureDataLookup; On 2017/06/14 23:17:12, Siggi Cherem (dart-lang) wrote: ...
3 years, 6 months ago (2017-06-14 23:44:13 UTC) #4
Emily Fortuna
https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/compiler.dart File pkg/compiler/lib/src/compiler.dart (right): https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/compiler.dart#newcode147 pkg/compiler/lib/src/compiler.dart:147: closureMapping.ClosureTask closureDataLookup; On 2017/06/14 23:44:13, Emily Fortuna wrote: > ...
3 years, 6 months ago (2017-06-14 23:54:12 UTC) #5
Emily Fortuna
Committed patchset #2 (id:40001) manually as e6d7c0500c4403e4f26a13ecdd57b4ab7197ba30 (presubmit successful).
3 years, 6 months ago (2017-06-14 23:56:02 UTC) #8
Siggi Cherem (dart-lang)
3 years, 6 months ago (2017-06-15 00:09:01 UTC) #9
Message was sent while issue was closed.
lgtm

https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closur...
File pkg/compiler/lib/src/closure.dart (right):

https://codereview.chromium.org/2938853004/diff/1/pkg/compiler/lib/src/closur...
pkg/compiler/lib/src/closure.dart:32: abstract class ClosureDataLookup<T> {
On 2017/06/14 23:44:13, Emily Fortuna wrote:
> On 2017/06/14 23:17:12, Siggi Cherem (dart-lang) wrote:
> > another reason I'd change *Info below to *Data :-)
> 
> I messaged you in chat about this:
> 
> For me, as a native English speaker, "data" has a slightly different sense
than
> "info", which is why I used one in one place and one in the other. 
> 
> "info" basically always refers to a single bit of information
> whereas "data" can refer to to the collective of details
> hence me using "info" in one place and "data" in the other
> do you still think I should keep it "data" throughout?

Thanks, to bring the full loop of the discussion: "info" sgtm :) - we should
review existing uses of Data elsewhere in the compiler and change to Info if
they fit in a similar category. Very low-pri though :)

Powered by Google App Engine
This is Rietveld 408576698