DescriptionSimplify Command classes.
- Get rid of separate CommandBuilder class and singleton pattern. It
was being passed around explicitly even though half of the places
that received a CommandBuilder as a parameter still directly called
CommandBuilder.instance instead of using it.
- Get rid of Command caching. As far as I can tell, it makes no
measurable difference in runtime performance or memory usage. Even
with a large invocation of a lot of configurations and tests, the
Command classes don't seem to be a significant use of memory.
- Shorten the factory names. "get" adds no value, and we know it
returns a "Command" since it's on Command.
R=whesse@google.com
Committed: https://github.com/dart-lang/sdk/commit/a6ca718e987608a2e3dde5c3540f6a97aba2cc48
Patch Set 1 #Patch Set 2 : Move Command and CommandOutput classes to separate files. #
Total comments: 6
Patch Set 3 : Merge branch 'master' into command-refactor #Patch Set 4 : Rename class. #
Messages
Total messages: 12 (4 generated)
|