Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(501)

Unified Diff: third_party/WebKit/Source/core/frame/UseCounter.h

Issue 2895243002: Rename requireUserMediation to preventSilentAccess in the CM API. (Closed)
Patch Set: rebase Created 3 years, 7 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/frame/UseCounter.h
diff --git a/third_party/WebKit/Source/core/frame/UseCounter.h b/third_party/WebKit/Source/core/frame/UseCounter.h
index ec8d20100698ea1b8533a16dc687035d67503245..61da33776916bfd0858bb2c915801473be9e9f0f 100644
--- a/third_party/WebKit/Source/core/frame/UseCounter.h
+++ b/third_party/WebKit/Source/core/frame/UseCounter.h
@@ -708,7 +708,7 @@ class CORE_EXPORT UseCounter {
kCredentialManagerGetMediationOptional = 961,
kCredentialManagerGetMediationSilent = 962,
kCredentialManagerStore = 963,
- kCredentialManagerRequireUserMediation = 964,
+ kCredentialManagerPreventSilentAccess = 964,
// The above items are available in M47 branch.
kBlockableMixedContentInSubframeBlocked = 966,
@@ -1602,6 +1602,7 @@ class CORE_EXPORT UseCounter {
kShapeDetection_BarcodeDetectorConstructor = 1991,
kShapeDetection_FaceDetectorConstructor = 1992,
kShapeDetection_TextDetectorConstructor = 1993,
+ kCredentialManagerRequireUserMediation = 1994,
jochen (gone - plz use gerrit) 2017/05/23 11:07:56 please keep the old name for 964, and use the new
vasilii 2017/05/23 12:34:19 Done.
// Add new features immediately above this line. Don't change assigned
// numbers of any item, and don't reuse removed slots.

Powered by Google App Engine
This is Rietveld 408576698