Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(616)

Unified Diff: third_party/WebKit/Source/core/paint/PaintInvalidator.cpp

Issue 2850633003: Rename LayoutTable::CollapseBorders() to ShouldCollapseBorders() (Closed)
Patch Set: Rebase Created 3 years, 8 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/paint/PaintInvalidator.cpp
diff --git a/third_party/WebKit/Source/core/paint/PaintInvalidator.cpp b/third_party/WebKit/Source/core/paint/PaintInvalidator.cpp
index df2ac59b77a68bcac2a2bb321d740589b8d62c3b..5317ac92f498bbbcecb2e8b109922c1bcccbf7fc 100644
--- a/third_party/WebKit/Source/core/paint/PaintInvalidator.cpp
+++ b/third_party/WebKit/Source/core/paint/PaintInvalidator.cpp
@@ -227,7 +227,7 @@ void PaintInvalidator::UpdatePaintingLayer(const LayoutObject& object,
// on the table's layer.
if (object.IsTable()) {
const LayoutTable& table = ToLayoutTable(object);
- if (table.CollapseBorders() && !table.CollapsedBorders().IsEmpty())
+ if (table.ShouldCollapseBorders() && !table.CollapsedBorders().IsEmpty())
context.painting_layer->SetNeedsPaintPhaseDescendantBlockBackgrounds();
}
« no previous file with comments | « third_party/WebKit/Source/core/paint/BoxPainter.cpp ('k') | third_party/WebKit/Source/core/paint/TableCellPainter.cpp » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698