Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(836)

Unified Diff: content/browser/payments/payment_manager.cc

Issue 2785523003: PaymentHandler: Rename PaymentAppManager to PaymentManager. (Closed)
Patch Set: PaymentHandler: Rename PaymentAppManager to PaymentManager. Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « content/browser/payments/payment_manager.h ('k') | content/browser/payments/payment_manager_unittest.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: content/browser/payments/payment_manager.cc
diff --git a/content/browser/payments/payment_app_manager.cc b/content/browser/payments/payment_manager.cc
similarity index 73%
rename from content/browser/payments/payment_app_manager.cc
rename to content/browser/payments/payment_manager.cc
index 9735028bdf1f8987b57d388b45d1b74e7b22c5ac..6d77f7ce7befb2dc69be482231915b567622bce0 100644
--- a/content/browser/payments/payment_app_manager.cc
+++ b/content/browser/payments/payment_manager.cc
@@ -2,7 +2,7 @@
// Use of this source code is governed by a BSD-style license that can be
// found in the LICENSE file.
-#include "content/browser/payments/payment_app_manager.h"
+#include "content/browser/payments/payment_manager.h"
#include <utility>
@@ -17,13 +17,13 @@
namespace content {
-PaymentAppManager::~PaymentAppManager() {
+PaymentManager::~PaymentManager() {
DCHECK_CURRENTLY_ON(BrowserThread::IO);
}
-PaymentAppManager::PaymentAppManager(
+PaymentManager::PaymentManager(
PaymentAppContextImpl* payment_app_context,
- mojo::InterfaceRequest<payments::mojom::PaymentAppManager> request)
+ mojo::InterfaceRequest<payments::mojom::PaymentManager> request)
: payment_app_context_(payment_app_context),
binding_(this, std::move(request)),
weak_ptr_factory_(this) {
@@ -31,16 +31,15 @@ PaymentAppManager::PaymentAppManager(
DCHECK(payment_app_context);
binding_.set_connection_error_handler(
- base::Bind(&PaymentAppManager::OnConnectionError,
- base::Unretained(this)));
+ base::Bind(&PaymentManager::OnConnectionError, base::Unretained(this)));
}
-void PaymentAppManager::Init(const std::string& scope) {
+void PaymentManager::Init(const std::string& scope) {
DCHECK_CURRENTLY_ON(BrowserThread::IO);
scope_ = GURL(scope);
}
-void PaymentAppManager::SetManifest(
+void PaymentManager::SetManifest(
payments::mojom::PaymentAppManifestPtr manifest,
const SetManifestCallback& callback) {
DCHECK_CURRENTLY_ON(BrowserThread::IO);
@@ -52,15 +51,15 @@ void PaymentAppManager::SetManifest(
scope_, std::move(manifest), callback);
}
-void PaymentAppManager::GetManifest(const GetManifestCallback& callback) {
+void PaymentManager::GetManifest(const GetManifestCallback& callback) {
DCHECK_CURRENTLY_ON(BrowserThread::IO);
payment_app_context_->payment_app_database()->ReadManifest(scope_, callback);
}
-void PaymentAppManager::OnConnectionError() {
+void PaymentManager::OnConnectionError() {
DCHECK_CURRENTLY_ON(BrowserThread::IO);
- payment_app_context_->PaymentAppManagerHadConnectionError(this);
+ payment_app_context_->PaymentManagerHadConnectionError(this);
}
} // namespace content
« no previous file with comments | « content/browser/payments/payment_manager.h ('k') | content/browser/payments/payment_manager_unittest.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698