Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(1517)

Unified Diff: content/browser/payments/payment_app_content_unittest_base.h

Issue 2785523003: PaymentHandler: Rename PaymentAppManager to PaymentManager. (Closed)
Patch Set: PaymentHandler: Rename PaymentAppManager to PaymentManager. Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « content/browser/BUILD.gn ('k') | content/browser/payments/payment_app_content_unittest_base.cc » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: content/browser/payments/payment_app_content_unittest_base.h
diff --git a/content/browser/payments/payment_app_content_unittest_base.h b/content/browser/payments/payment_app_content_unittest_base.h
index 7e98f00826eadfa8aaf1d24bfb9d07c3c476e79c..9461e5fadd81a649614589221fbd4b52e73059ed 100644
--- a/content/browser/payments/payment_app_content_unittest_base.h
+++ b/content/browser/payments/payment_app_content_unittest_base.h
@@ -12,7 +12,7 @@
#include "base/macros.h"
#include "base/memory/ref_counted.h"
#include "components/payments/content/payment_app.mojom.h"
-#include "content/browser/payments/payment_app_manager.h"
+#include "content/browser/payments/payment_manager.h"
#include "testing/gtest/include/gtest/gtest.h"
#include "url/gurl.h"
@@ -29,13 +29,13 @@ class PaymentAppContentUnitTestBase : public testing::Test {
~PaymentAppContentUnitTestBase() override;
BrowserContext* browser_context();
- PaymentAppManager* CreatePaymentAppManager(const GURL& scope_url,
- const GURL& sw_script_url);
- void SetManifest(PaymentAppManager* manager,
+ PaymentManager* CreatePaymentManager(const GURL& scope_url,
+ const GURL& sw_script_url);
+ void SetManifest(PaymentManager* manager,
payments::mojom::PaymentAppManifestPtr manifest,
- const PaymentAppManager::SetManifestCallback& callback);
- void GetManifest(PaymentAppManager* manager,
- const PaymentAppManager::GetManifestCallback& callback);
+ const PaymentManager::SetManifestCallback& callback);
+ void GetManifest(PaymentManager* manager,
+ const PaymentManager::GetManifestCallback& callback);
payments::mojom::PaymentAppManifestPtr CreatePaymentAppManifestForTest(
const std::string& name);
void UnregisterServiceWorker(const GURL& scope_url);
@@ -52,7 +52,7 @@ class PaymentAppContentUnitTestBase : public testing::Test {
std::unique_ptr<TestBrowserThreadBundle> thread_bundle_;
std::unique_ptr<PaymentAppForWorkerTestHelper> worker_helper_;
- std::vector<payments::mojom::PaymentAppManagerPtr> payment_app_managers_;
+ std::vector<payments::mojom::PaymentManagerPtr> payment_managers_;
DISALLOW_COPY_AND_ASSIGN(PaymentAppContentUnitTestBase);
};
« no previous file with comments | « content/browser/BUILD.gn ('k') | content/browser/payments/payment_app_content_unittest_base.cc » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698