Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(423)

Unified Diff: third_party/WebKit/Source/web/WebFrameImplBase.h

Issue 2764773003: Change WebFrameImplBase::initializeCoreFrame to take a Page& (Closed)
Patch Set: Rebase Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
« no previous file with comments | « third_party/WebKit/Source/web/WebFrame.cpp ('k') | third_party/WebKit/Source/web/WebLocalFrameImpl.h » ('j') | no next file with comments »
Expand Comments ('e') | Collapse Comments ('c') | Show Comments Hide Comments ('s')
Index: third_party/WebKit/Source/web/WebFrameImplBase.h
diff --git a/third_party/WebKit/Source/web/WebFrameImplBase.h b/third_party/WebKit/Source/web/WebFrameImplBase.h
index 9b5367c5772e99afffb85eac4e3bf66b5ab266b2..8134801532a4b81a16d6ba6cc28012074556980d 100644
--- a/third_party/WebKit/Source/web/WebFrameImplBase.h
+++ b/third_party/WebKit/Source/web/WebFrameImplBase.h
@@ -12,8 +12,8 @@
namespace blink {
class Frame;
-class FrameHost;
class FrameOwner;
+class Page;
// WebFrameImplBase exists to avoid the diamond inheritance problem:
// - The public interfaces WebLocalFrame/WebRemoteFrame extend WebFrame.
@@ -33,7 +33,7 @@ class WEB_EXPORT WebFrameImplBase
public:
virtual ~WebFrameImplBase();
- virtual void initializeCoreFrame(FrameHost*,
+ virtual void initializeCoreFrame(Page&,
FrameOwner*,
const AtomicString& name) = 0;
// TODO(dcheng): Rename this to coreFrame()? This probably also shouldn't be
« no previous file with comments | « third_party/WebKit/Source/web/WebFrame.cpp ('k') | third_party/WebKit/Source/web/WebLocalFrameImpl.h » ('j') | no next file with comments »

Powered by Google App Engine
This is Rietveld 408576698