Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(127)

Unified Diff: src/snapshot/snapshot.h

Issue 2736923002: SnapshotCreator: start from existing snapshot if we have one (Closed)
Patch Set: Created 3 years, 9 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: src/snapshot/snapshot.h
diff --git a/src/snapshot/snapshot.h b/src/snapshot/snapshot.h
index 010072a694f67568f2299452555628d3d26ed30f..7a7274cae8b4b4aa2167b93e3c46fd097440e887 100644
--- a/src/snapshot/snapshot.h
+++ b/src/snapshot/snapshot.h
@@ -39,13 +39,15 @@ class SnapshotData : public SerializedData {
bool IsSane();
// The data header consists of uint32_t-sized entries:
- // [0] magic number and external reference count
- // [1] version hash
- // [2] number of reservation size entries
- // [3] payload length
+ // [0] magic number and (internal) external reference count
+ // [1] API-provided external reference count
+ // [2] version hash
+ // [3] number of reservation size entries
+ // [4] payload length
// ... reservations
// ... serialized payload
- static const int kCheckSumOffset = kMagicNumberOffset + kInt32Size;
+ static const int kCheckSumOffset =
Yang 2017/03/07 11:28:11 Now that I see it, this name is a bit misleading.
Jakob Kummerow 2017/03/07 12:39:15 Done (moved).
+ kExtraExternalReferencesOffset + kInt32Size;
static const int kNumReservationsOffset = kCheckSumOffset + kInt32Size;
static const int kPayloadLengthOffset = kNumReservationsOffset + kInt32Size;
static const int kHeaderSize = kPayloadLengthOffset + kInt32Size;

Powered by Google App Engine
This is Rietveld 408576698