Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(724)

Unified Diff: third_party/WebKit/Source/core/plugins/PluginView.h

Issue 2723993002: Rename platform/Widget to platform/FrameViewBase in core. (Closed)
Patch Set: Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/core/plugins/PluginView.h
diff --git a/third_party/WebKit/Source/core/plugins/PluginView.h b/third_party/WebKit/Source/core/plugins/PluginView.h
index 0f799cbcb3421b2ee17ff6c452402e488ee9cccb..97f2361894d1fd51e7d352a577fefc0b1b2d8bfe 100644
--- a/third_party/WebKit/Source/core/plugins/PluginView.h
+++ b/third_party/WebKit/Source/core/plugins/PluginView.h
@@ -29,7 +29,7 @@
#define PluginView_h
#include "core/CoreExport.h"
-#include "platform/Widget.h"
+#include "platform/FrameViewBase.h"
#include "platform/scroll/ScrollTypes.h"
#include "v8/include/v8.h"
#include "wtf/text/WTFString.h"
@@ -42,7 +42,7 @@ namespace blink {
class ResourceResponse;
-class CORE_EXPORT PluginView : public Widget {
+class CORE_EXPORT PluginView : public FrameViewBase {
public:
bool isPluginView() const final { return true; }
@@ -62,14 +62,14 @@ class CORE_EXPORT PluginView : public Widget {
virtual void invalidatePaintIfNeeded() {}
protected:
- PluginView() : Widget() {}
+ PluginView() : FrameViewBase() {}
};
DEFINE_TYPE_CASTS(PluginView,
- Widget,
- widget,
- widget->isPluginView(),
- widget.isPluginView());
+ FrameViewBase,
+ frameViewBase,
+ frameViewBase->isPluginView(),
+ frameViewBase.isPluginView());
} // namespace blink

Powered by Google App Engine
This is Rietveld 408576698