Chromium Code Reviews
chromiumcodereview-hr@appspot.gserviceaccount.com (chromiumcodereview-hr) | Please choose your nickname with Settings | Help | Chromium Project | Gerrit Changes | Sign out
(945)

Unified Diff: third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp

Issue 2708153005: Rename SurfaceIdAllocator to LocalSurfaceIdAllocator (Closed)
Patch Set: Delete useless include Created 3 years, 10 months ago
Use n/p to move between diff chunks; N/P to move between comments. Draft comments are only viewable by you.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp
diff --git a/third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp b/third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp
index bf8a9a3bf10029d464ee1387b4c22e9b811e5116..a00f33bfcab084dc8b46912135dd2bc49f6c48e4 100644
--- a/third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp
+++ b/third_party/WebKit/Source/platform/graphics/OffscreenCanvasFrameDispatcherImpl.cpp
@@ -46,7 +46,7 @@ OffscreenCanvasFrameDispatcherImpl::OffscreenCanvasFrameDispatcherImpl(
if (m_frameSinkId.is_valid()) {
// Only frameless canvas pass an invalid frame sink id; we don't create
// mojo channel for this special case.
- m_currentLocalSurfaceId = m_surfaceIdAllocator.GenerateId();
+ m_currentLocalSurfaceId = m_localSurfaceIdAllocator.GenerateId();
DCHECK(!m_sink.is_bound());
mojom::blink::OffscreenCanvasCompositorFrameSinkProviderPtr provider;
Platform::current()->interfaceProvider()->getInterface(
@@ -375,7 +375,7 @@ void OffscreenCanvasFrameDispatcherImpl::dispatchFrame(
}
if (m_changeSizeForNextCommit) {
- m_currentLocalSurfaceId = m_surfaceIdAllocator.GenerateId();
+ m_currentLocalSurfaceId = m_localSurfaceIdAllocator.GenerateId();
m_changeSizeForNextCommit = false;
}

Powered by Google App Engine
This is Rietveld 408576698